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1680A/AD-Series and 1690A/AD-Series
Logic Analyzers

The Following manual is a copy of the 1680/90 logic analyzer online help system.
Information covering the operation of any "Add-in" tools listed in the Tools Menu of
the product is covered in separate documentation for those tools.

1680A/AD-Series

1690A/AD-Series
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Tutorial
Getting to know your logic analyzer

The following tutorial is intended to give new users a quick overview of logic analyzer
basics.  In addition to learning the concepts of logic analysis, you will see some of the
logic analyzer's more common features by going through a measurement overview.
Finally, you are shown some easy time saving tasks that can quickly make you as
productive as the more experienced user.

Logic analysis basics
� When should I use an oscilloscope

� When should I use a logic analyzer

� What is a logic analyzer

Timing analyzer

Clocking

Sampling

Triggering

State analyzer

Clocking

Sampling

Triggering

� Probing options

Measurement overview
The following overview does not require an active target system.  However, in order to
show features that work on data, you are asked to load a configuration file between steps
5 and 6 that contains data to finish the exercise.

� Turning on the logic analyzer

� Connecting to the target system

� Setting up bus/signal names

� Setting the acquisition mode

� Setting up a simple trigger

� Open the tutorial configuration file

� Using markers

� Zooming in on the data

Time saving tasks
� Loading and saving configuration files

� Saving and recalling trigger setups

� Quick marker measurements

� Searching data

� Toolbars and mouse shortcuts

See Also
Product overview
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Logic analyzer basics

When should I use an oscilloscope
     


Generally, an oscilloscope is used when you need precise parametric information such as
time intervals and voltage readings.

More specifically:

� When you need to measure small voltage excursions on your signals such as
undershoot or
overshoot.

� When you need high time-interval accuracy.  Oscilloscopes can capture precise
parametric information such as the time between two points on a rising edge of a
pulse with very high
accuracy.
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When should I use a logic analyzer
     


Generally, a logic analyzer is used to view timing relationships among many signals, or if
you need to trigger on patterns of logic highs and lows.  A logic analyzer reacts the same
way as the logic circuits do when a voltage threshold is crossed by a signal in the device
under test.  It will recognize the signal to be either low or high.

More specifically:

� When you need to see many signals at once. Logic analyzers are very good at
organizing and displaying multiple signals.  A common task is to group multiple
signals into a bus and assign a custom name.  Good examples are address, data,
and control buses.

� When you need to look at signals in your system the same way your hardware
does. Signals are displayed on a time axis so you can see when transitions occur
relative to other bus signals or clock signals.

� When you need to trigger on a unique bus pattern or signal edge. Logic analyzers
can be configured to store data when the high or low values of a group (bus) of
signals match a predefined pattern. Logic analyzers can be configured to store
data when a specific edge or level is detected on a single signal.



21

What is a Logic Analyzer

What is a Logic Analyzer
     


Now that we've talked a little about when to use a logic analyzer, let's look in more detail
at what a logic analyzer is. Up to now, we've used the term "logic analyzer" rather
loosely. In fact, most logic analyzers are really two analyzers in one.

What is a timing analyzer
A timing analyzer is the part of a logic analyzer that is analogous to an oscilloscope. As a
matter of fact, they can be thought of as close cousins.

The timing analyzer displays information in the same general form as a scope, with the
horizontal axis representing time and the vertical axis as voltage amplitude. Because the
waveforms on both instruments are time-dependent, the displays are said to be in the
"time domain".

The basic areas of functionality in a timing analyzer are as follows:

Clocking data in the timing analyzer

Sampling in the timing analyzer

Triggering the timing analyzer

What is a state analyzer
A state analyzer is very good at tracking down bugs in software or defective components
in hardware. It can help eliminate the question whether a problem is in the software code
or some hardware device.

Most often, state analyzers are used to find out what logic levels are present on a bus
when a particular clock signal occurs.  In other words, you want to know what "state of
activity" is present when the clock occurs and data is suppose to be valid.  Data captured
in memory is displayed in a listing format with a time tag attached to every state.

The basic areas of functionality in a state analyzer are as follows:

Clocking data in the state analyzer

Sampling in the state analyzer

Triggering the state analyzer
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Clocking data in the timing analyzer
     


The timing analyzer uses it's own internal clock to control the sampling of data.  This type
of clocking makes the sampling of data in the logic analyzer asynchronous to the
clocking in the device under test.

More specifically:

� A timing analyzer is good at showing you "When" signal activity occurs "Relative to
other signals".

� A timing analyzer is more interested in viewing the timing relationships between
individual signals, than the timing relationships to the signals that are controlling
execution in the device under test.

� This is why a timing analyzer can sample data "out of sync", or asynchronous to
the target system clock signals.



23

Sampling in the timing analyzer
     


The timing analyzer works by sampling the input waveforms to determine whether they
are high or low. It determines a high or low by comparing the voltage level of the
incoming signal to a user-defined voltage threshold. If the signal is above that threshold
when it samples, it will be displayed as a 1 or high by the analyzer.  By the same
criterion, any signal sampled that is below threshold is displayed as a 0 or low.

The figure below illustrates how a logic analyzer samples a sine wave as it crosses the
threshold level.

The sample points are then stored in memory and used to reconstruct a more squared-off
digital waveform.

This tendency to square everything up would seem to limit the usefulness of a timing
analyzer. However, a timing analyzer is not intended as a parametric instrument. If you
want to check rise time of a signal with an analyzer, you should use a scope. But if you
need to verify timing relationships among several or hundreds of signals by seeing them
all together, a timing analyzer is the right choice.

Sampling accuracy
When the timing analyzer samples an input channel, it is either high or low. If the
channel is at one state (high or low) on one sample, and the opposite state on the next
sample, the analyzer "knows" that the input signal has transitioned sometime between
the two samples. It doesn't know when, so it places the transition point at the next
sample, as shown in the figure below.
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This presents some ambiguity as to when the transition actually occurred and when it is
displayed by the analyzer.

Worst case for this ambiguity is one sample period, assuming that the transition occurred
immediately after the previous sample point.

With this technique however, there is a trade-off between resolution and total acquisition
time. Remember that every sampling point uses one memory location. Thus, the higher
the resolution (faster sampling rate), the shorter the acquisition window.
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Triggering the timing analyzer
     


At some point in a measurement, the logic analyzer has to know when to capture (store)
the data that is flowing through it's memory.  This is know as the trigger point.

One way to get the analyzer to trigger is to configure the analyzer to look for either a
pattern of highs and lows from a group of signals (bus), or a rising or falling edge from a
single signal.  When the analyzer sees the specified patterns or edges in data, it triggers.

Pattern Trigger
Pattern triggers are used to find specific patterns of highs and lows across a bus.  You can
specify different kinds of criteria such as equal, not equal, in or out of a range, or greater
than/less than.

Example: You have a bus containing 8 signal lines. You configure the Simple Trigger to
specify that the analyzer triggers when the incoming data is equal to a pattern of "AA".

To make things easier for some users, the trigger point on most analyzers can be set not
only in Hex, but in binary (1's and 0's), octal, ASCII, or decimal.  For instance, the Hex
trigger value of AA could also be set to an equivalent binary trigger value of 0101 0101.
However, using hex for the trigger point is particularly helpful when looking at buses that
are 16, 24, 32, or 64 bits wide.

Edge Trigger
Edge triggering is a familiar concept to those accustomed to using an oscilloscope. When
adjusting the "trigger level" knob on a scope, you could think of it as setting the level of a
voltage comparator that tells the scope to trigger when the input voltage crosses that
level. A timing analyzer works essentially the same on edge triggering except that the
trigger level is preset to a logic threshold.

While many logic devices are level dependent, clock and control signals of these devices
are often edge-sensitive. Edge triggering allows you to start capturing data as the device
is clocked.
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Example:  Take the case of an edge-triggered shift register that is not shifting data
correctly.  Is the problem with the data or the clock edge? In order to check the device,
we need to verify the data when it is clocked – on the clock edge.  The analyzer can be
told to capture data when the clock edge occurs (rising or falling) and catch all of the
outputs of the shift register.
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Clocking data in the state analyzer
     


The state analyzer requires a clock signal from the target system.  This type of clocking
makes the sampling of data in the logic analyzer synchronous to the clocked events on
the device under test.

More specifically:

� A state analyzer is good at showing you "What" the signal activity is during a
"Valid clock or control signal".

� A state analyzer is more interested in viewing signal activity during specified times
of target system execution, than signal activity unrelated to the target system
timing.

� This is why a state analyzer wants to sample data that is "synchronized" or
synchronous to the target system clock signals.
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Sampling in the state analyzer
     


In the world of microprocessors, you can have both data and address appearing on the
same signal lines. To capture the correct data, the state analyzer has to restrict the
sampling of data to times when only the desired data is valid and appears on the signal
lines. It does this by sampling data from the same signal lines but with different clocks.

Example:  The following timing diagram shows that to capture addresses, we want the
analyzer to sample when MREQ line goes low.

 To capture data, we want the analyzer to sample when the WR line goes low (write cycle)
or when RD goes low (read cycle).
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Triggering the state analyzer
     


Similar to a timing analyzer, a state analyzer has the capability to qualify the data we
want to store.  If we are looking for a specific pattern of highs and lows on the address
bus, we can tell the analyzer to start storing when it finds that pattern and to continue
storing until the analyzer's memory is full.

Simple Trigger Example:  Looking at the "D" flip-flop shown below, data on the "D" input
is not valid until after a positive-going clock edge occurs.  Thus, a valid state for the flip-
flop is when the clock input is high.

 Now imagine that we have eight of these flip-flops in parallel.  All eight are connected to
the same clock signal as shown below.

 When a high level occurs on the clock line, all eight capture data at their "D" inputs.
Again, a valid state occurs each time there is a positive level on the clock line.

 The following simple trigger tells the analyzer to collect data on lines D0 - D7 when a high
level is on the clock line.
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Advanced Trigger Example:  You want to see what data is stored in memory at the
address value 406F6.  You configure the advanced trigger to look for the pattern 406F6
(hexadecimal) on the address bus and a high level on the RD (memory read) clock line.

 As you configure the Edge And Pattern trigger dialog, try to think of it as constructing a
sentence that reads left-to-right.

 "Find the first occurrence of a Bus named ADDR, and on All bits a pattern that Equals
406F6 Hex, And a Signal named RD with a High level.  Then Trigger and fill memory
with Anything.
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Probing options
     


� General Purpose Probing (Standard)

� Adapter to board connectors (Optional)

� Analysis probes (Optional)

So far we've talked about some of the differences between scopes, timing and state
analyzers. Before we're ready to apply these new tools, we should talk about one more
subject – the probing system.

A scope probe is designed to gain easy access to the target system while minimizing the
signal distortion. Since we want to look at parametric information like voltage levels and
rise times, it is important that the probe doesn't load the circuit under test significantly. A
typical scope probe has 1 M ohm impedance shunted by 10 pF, depending on the
bandwidth required.

Logic analyzer probes are designed to allow connection of a high number of channels to
the target system easily by trading off amplitude accuracy of the signal under test.
Remember that a logic analyzer only distinguishes between two voltage levels!

Traditionally, logic analyzers used active probe pods, which had an integrated signal
detection circuitry for eight channels integrated. From these pods, we could connect with
leads to the circuit under test.

The typical impedance of a logic analyzer probe is in the area of 100 k ohm shunted by 8
pF at the input of the active pod. The connecting wires, however, add another 8 pF stray
capacitance, giving a total of 16 pF per channel.

General Purpose Probing
Physical connections to digital systems must be reliable and convenient to deliver
accurate data to the logic analyzer with minimum intrusion to the target system.  The
standard general purpose probing solution shown below is shipped with the logic
analyzer.  Each channel is terminated at both ends with 100k ohm and 8 pF.
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The standard set plugs directly into any .1-inch grid with 0.026 to 0.033-inch diameter
round pins or 0.025-inch square pins.  All probe tips work with the Agilent Technologies
5059-4356 surface mount grabbers and the Agilent Technologies 5959-0288 through-hole
grabbers.
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Adaptor to board connectors

Both the 01650-63203 and the E5346A adapters include termination for the logic
analyzer. The 01650-63203 termination adapter plugs into a 2 x 10 pin header with 0.1
inch spacing. The E5346A high-density adapter connects to an AMP "Mictor 38"
connector.

Analysis Probes
Connecting a state analyzer to a microprocessor system requires some effort in terms of
mechanical connection and clock selection. Remember, we have to clock the state
analyzer whenever data or addresses on the bus are valid. With some microprocessors it
might be necessary to use external circuitry to decode several signals to derive the clock
for the state analyzer.

Analysis probes (formerly called preprocessors) are microprocessor-specific interfaces
that make it easier to probe buses. Generally, analysis probes consist of a circuit board
that attaches to the microprocessor (possibly through an adapter) and a configuration
file. The configuration file sets up the logic analyzer's clocks, buses, and signals correctly,
and may include an inverse assembler. The circuit board provides access to logical groups
of pins through headers designed to connect directly to the logic analyzer.
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Measurement overview

Turning on the logic analyzer
     


1. Plug in the power cable and press the front-panel On/Off button.

2. From the Windows Start bar, click Start>Programs>Agilent Logic
Analyzer>Agilent Logic Analyzer.

Optional:  If you have a logic analyzer shortcut icon on screen, double-click the icon.
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Connecting to the target system
     


The standard probing that comes with the logic analyzer is the passive general purpose
probe with sixteen channels per cable. Each channel is terminated at both ends with 100k
ohm and 8 pF.  With this type of probing, you can also disconnect the leads and plug the
cable connector directly into a connector on the device under test.

Note:  In this tutorial, no probe connections are required.  Later on in this tutorial, you are
asked to load a configuration file containing data to simulate the results of a probed device
under test.  However, at this time, if you have the credit card demo board available, you
can connect it and capture real data for this tutorial.

As the number of channel connections increase, other probing options may be more
convenient.
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Credit card demo board
  


If you have a credit card demo board available, you can connect it as shown below and
capture the same data used in this measurement overview.  Other benefits are that you
will see real activity indicators in the bus/signal setup dialog.

1. Connect the probe cable of Pod 1 into connector J1 of the demo board.
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Setting up bus/signal names
     


By default, the analyzer has two buses (My Bus 1 & 2) and two signals (My Signal 1 & 2)
configured in the interface.  The following exercise cleans up the display defaults and re-
configures the analyzer bus/signal setup for a new measurement.

Delete bus/signal names
1. In the menu bar click Setup>Buses/Signals.

2. In the Analyzer Setup dialog that appears, right-click on My Bus 1, then select
Delete.  Repeat until all bus signal names are deleted.  After the last bus/signal
is deleted, "My Bus 1" appears again as a default name.

Tip:  You can delete all bus/signal configurations at once with the Delete All
button.

Add new bus/signal name
1. In the Analyzer Setup dialog, right-click on My Bus 1, then select Rename.

2. From the popup keypad that appears, type in the new name "counter".

3. Select Ok.
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Map signals into the analyzer
The analyzer must be told which probed signals from the device under test are to be
included in the measurement, and how you want them grouped in the analyzer.  In this
exercise, you assign channels 0 - 7 on Pod 1 under the name "counter".  Notice that
when more than one channel is assigned to "counter" it becomes a bus.

1. Check the activity indicators for verification of proper connection to the target
system.  You should see a transition arrow on all 8 channels.

Note:  If you have the credit card demo board connected for this tutorial, you
will see activity indicators as shown below.  If you will be loading the demo
configuration file (later in this tutorial) you will not see activity.

1. Click each channel assignment box under channels 0 - 7 on Pod 1.  Notice that
as you assign channels, the configuration information is updated for the
bus/signal.

2. Click Ok.
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Setting the acquisition mode
     


Under the Sampling tab of the Analyzer Setup dialog is where you set the analyzer to be
either a timing or state analyzer.  You also set either the timing options, such as memory
depth or sampling period, or the state clocking options.

1. From the menu bar, click Setup>Timing/State (Sampling)... ., or click the

  icon in the toolbar.

2. Select Timing - Asynchronous Sampling.

3. Click Ok.
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Setting up a simple trigger
     


The Simple Trigger is a quick way to configure the analyzer to trigger on either a data
pattern on a bus, or an attribute of a single signal such as a rising edge or a low logic
level.

1. In the Simple Trigger, click on the pattern qualifier   and set it to Equal.

2. Click in the text entry field   and enter the data pattern "E5".
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Open the tutorial configuration file
     


At this point in a measurement, you would normally run the logic analyzer.  However,
because you are not connected to a device under test, you cannot capture real data.  You
will have to load a configuration file that contains this data.

Load the configuration file
1. Select File>Open.

2. From the file manager dialog, select the file named DemoConfig.ala from the
following directory: C:\Documents and Settings\All
Users\Documents\Agilent Technologies\Logic Analyzer\Provided
Configs\Agilent\Help Demo\

3. Select Open.

View the data
Notice how the logic analyzer triggered on data pattern E5 and placed it in the center of
the display.  The red line shows that the trigger point is at the start of the data pattern
E5.
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Using markers
     


Markers are used for creating reference points in data.  Once markers are placed in data,
you can use them to quickly see what time, sample, or data value the marker is set on.

To create a marker
1. From the menu bar, click Markers>New.

2. From the New Marker dialog that appears, configure the new marker and if
desired, specifically a position it in data.  When you do not position the marker,
by default it is placed at the trigger point.

3. Select Ok.

To place a marker in data
When you first create a new marker, you have the option to place it in data at a specific
point in time or a specific sample number.  The following exercise shows you other ways
to position markers in data.

1. In the display, click on marker M3 (your new marker) and while holding the
mouse button down, drag maker M3 to -100ns before trigger, then release.
Notice that the marker position value changes as you move it.

2. From the menu bar, click Markers>Place On Screen, then select M1 and click
Ok.  Notice how M1 is placed at center screen at the red trigger line.

3. Point the mouse cursor at any desired point in data, then right-click and select
Place Marker.  From the Place Marker dialog that appears, choose the M2
marker.  Notice that the marker is placed where the mouse was pointing.

Go To a marker in data
Once you have markers set in data, you can quickly find any of them as follows.

1. From the menu bar, click Markers>GoTo.

2. Select the marker you want to find, and click Ok.
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Zooming in on the data
     


Data from a timing analyzer is displayed similarly to oscilloscope data.  Both an analyzer
and scope display waveforms on a horizontal time axis.  Therefore to zoom in or out on a
waveform, change the Scale (time/division) of the time axis of the waveform.

Both state and timing analyzers can have multiple signals grouped together in a bus. To
get a view of all signals, you can expand a bus into individual signals.

Expand a bus
Click the "+" symbol just to the left of the bus named "counter".  The collection of signals
under "counter" breaks out into individual signals named counter[0] - counter[7].

Change the scale
Click the zoom out icon to expand the signals to where you want them.
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Time saving tasks

Loading and saving configuration files
     


Many times it is quicker to open an existing configuration file with a similar setup than to
create a new configuration from scratch.  You simply open a similar file, make the
appropriate changes to the setup, then save the file as a new filename.

Note:  When you rename an existing configuration file, you retain the saved trigger
setups and "Find" search favorites from the first configuration file.

You already have learned how to open a configuration file.  In the following exercise, you
will save the "democonfig" file to a new name.

1. From the menu bar, click File>Save As... .

2. From the file manager dialog that appears, type in the new name "myconfig",
then click Save.
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Saving and recalling trigger setups
     


Each time you setup a new trigger and run the measurement, the trigger setup is stored
in the analyzer.  It is quicker to recall a trigger setup rather than re-configure the trigger
setup each time.

Note: The analyzer must be run before the trigger setup is stored.  Also, trigger setups
are stored as part of the configuration file.  If you load a new configuration file, the trigger
setups will be overwritten by trigger setups stored with the new file.

To recall a trigger setup
1. From the menu bar, click Setup>Recall Trigger.

2. From the lower list, select the desired trigger setup, then click Ok.

Tip: When the list of most recently used triggers get long, you can store the most
often used triggers in the upper favorites list.
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Quick marker measurements
     


You can quickly read the time or number of samples between markers.

1. Click Markers>New Interval Measurement.

2. Configure the Interval dialog to display the Time from M1 to M2 as shown below,
then click Ok.

The result of the interval measurement  is displayed in the marker
measurements display bar.

3. Click Markers>New Value At Measurement.

4. Configure the Value At dialog to display the Hex value of counter at M1 as
shown below, then click Ok.

The result of the value at measurement   is displayed in the marker
measurement display bar.
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Searching data
     


You can search for a data pattern on a bus, or a single signal.  You can also choose when
the search begins and ends.  Finally, you can save the search criterion in a favorites list.

1. From the menu bar, click Edit>Find.

2. From the Find dialog that appears, configure the search criterion as shown below
to find "AA".

3. Select Ok.

As you configure the Find dialog, try to think of it as constructing a sentence that reads
left-to-right.

 "Find the 1st occurrence from Display Center, on a Bus named counter, including All
bits, a pattern that Equals AA".
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Toolbars, tooltips and mouse
shortcuts

  

Throughout this tutorial, the menu bar has been used to access features.  There are two
other ways to access features as well as other useful tips that can save you time.

Toolbars
Below the menu bar are groups of icons that represent shortcuts to many dialogs and
features.  For more information refer to Toolbars in the main help.

Mouse shortcuts
There are many mouse shortcuts available.  To access them simply point the mouse over
a screen element such as a marker, or screen area, then right-click the mouse.  Mouse
shortcuts are especially useful within the waveform and listing data display areas.

Tooltips
Tooltips are small information displays that appear during operations such as moving
markers, setting a trigger with the mouse, or hovering the mouse over a bus/signal
name.  Use them as comments, or to monitor your progress or current positions.
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Measurement Examples
The following measurement examples show you the typical order of steps to setup and
run a measurement.  As you go through the examples, you will encounter steps such as
probing or triggering where alternative choices are available.  In these steps, select the
probing or trigger example that best fits your measurement.

Making a timing analyzer measurement

Making a state analyzer measurement

To trigger other instruments - Trigger out

To trigger the analyzer from another instrument - Trigger in

See Also
Tutorial - Getting to know your logic analyzer

Timing mode trigger functions

State mode trigger functions

Making marker measurements
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Making a timing analyzer
measurement

The following measurement example shows you the steps necessary to configure and run
the logic analyzer for a typical timing analyzer measurement.  As you go through the
example, make the appropriate choices from the selection lists that best match the kind
of configuration you need.

Tip:  If you are new to logic analysis, refer to "Getting to know your logic analyzer"
for a quick tutorial on logic analysis concepts and measurements.

1. Connect the   to the device under test.

2. Turn on the logic analyzer.

Bus and signal setup
3. In the menu bar, select Setup>Bus/Signal... .

4. From the Buses/Signals tab, assign bus/signal names to the probed signals on the
target system.  You do this by either renaming existing names, or deleting and
creating new names.

5. From the Buses/Signals tab, assign channels under the appropriate pods for all
probed buses/signals on the device under test.

Acquisition mode setup
6. In the Analyzer Setup dialog, select the Sampling tab.

7. From the Sampling tab, set the acquisition mode to Timing - Asynchronous
Sampling.

8. Set the Sampling Options.

9. Set the Sampling Period.

Trigger setup
10. The trigger required to capture specific data depends on the measurement.

However, the trigger is generally set in two ways.

� From within the data display, setup a  .

� From the Advanced Trigger dialog, setup a timing mode 
function.

Run the measurement
11. Run the measurement.

See Also
To set the trigger position

To set acquisition depth
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Making a state analyzer measurement
The following measurement example shows you the steps necessary to configure and run
the logic analyzer for a typical state analyzer measurement.  As you go through the
example, make the appropriate choices from the selection lists that best match the kind
of configuration you need.

Tip:  If you are new to logic analysis, refer to "Getting to know your logic analyzer"
for a quick tutorial on logic analysis concepts and measurements.

1. Connect the   to the device under test.

Note: Be sure that the clock signals of your device under test are connected to
clock channels on the pods.  Any unused clock channels can be used for additional
data channels and will not feed into the state clock setup.

2. Turn on the logic analyzer.

Bus and signal setup
3. In the menu bar, select Setup>Bus/Signal... .

4. From the Buses/Signals tab, assign bus/signal names to the probed signals on the
target system.  You do this by either renaming existing names, or deleting and
creating new names.

5. From the Buses/Signals tab, assign channels under the appropriate pods for all
probed buses/signals on the device under test.

Acquisition mode setup
6. In the Analyzer Setup dialog, click the Sampling tab.

7. From the Sampling tab, set the acquisition mode to State - Synchronous
Sampling.

8. Set the state clock type.

9. Set the state clock qualifiers.

10. If necessary, set the advanced state clocking.

Trigger setup
11. The trigger required to capture specific data depends on the measurement.

However, the trigger is generally set in two ways.

� From within the data display, set up a  .

� From the Advanced Trigger dialog, set up an   function.

Run the measurement
12. Run the measurement.

See Also
To set the trigger position

To set acquisition depth



52

External Triggering
There are Trigger In and Trigger Out BNC connectors located on the logic analyzer
(rear panel of 1680-series and front panel of 1690-series).  Use them to connect the
analyzer to an external instrument and either send or receive a trigger signal.

Trigger signal characteristics
Trigger out signal:

The trigger out signal is designed to drive a 50 Ohm load.  It is recommended that for
good signal quality, the trigger out signal be terminated in 50 Ohms to ground.

VOH (output high level) = >2.0 V.

VOL (output low level) = <0.5 V.

Pulse width = Approximately 60 ns to 140 ns.

Signal type is set in the System Options dialog.  System Options is reached by
Edit>Options.

Trigger in signal:

TTL, ECL, or user defined 5.5 V Max.

Edge type is set in the System Options dialog.  System Options is reached by
Edit>Options.

The following tasks show you how to configure the analyzer for external triggering.  For
an example of a complete analyzer measurement, refer to the measurement examples
listed below under See Also.

To trigger other instruments - trigger out
 To trigger analyzer from another instrument - trigger in

To trigger other instruments - Trigger Out
1. Connect a BNC cable from the Trigger Out BNC to the external instrument you

want to trigger.

2. Configure the logic analyzer as you would normally for any other measurement.
Refer to See Also below.

3. When the analyzer's trigger sequence becomes true and the analyzer triggers, a
trigger signal is sent out through the Trigger Out BNC to the external
instrument.

To trigger analyzer from another instrument -
Trigger In

1. Connect a BNC cable from the Trigger In BNC to the external instrument that
will send the trigger signal.

2. Configure the logic analyzer as you would normally for any other measurement.
Refer to See Also.

3. From the menu bar select Setup>Advanced Trigger.

4. From the Trigger dialog, select the Other tab, then select the Wait for external
arm trigger function.
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5. When the logic analyzer receives the external arm signal (trigger signal), it arms
and begins to evaluate its trigger sequence.  When the trigger sequence becomes
true, the analyzer triggers.

See Also
Making a state analyzer measurement

Making a timing analyzer measurement

Wait for external arm - (state)

Wait for external arm - (timing)
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Making marker measurements

Making marker measurements
Once a marker is created, you can use it as a reference point in the data when measuring
intervals or viewing the data value at the marker.

To create a new interval measurement

To create a new value at measurement

See Also
Working with markers
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To create a new interval
measurement

Use the new interval measurement feature to measure a time interval, or the number of
samples between two specified points in data.  Measurement results are displayed in the
marker measurement display bar.

Note: Marker measurements use either the default M1 and M2 markers, or any other
user-defined markers.

1. From the menu bar select Markers>New Interval Measurement, or click the

 icon in the markers toolbar.

2. Select either time or sample, then select the markers you want to measure
between.

3. Click OK.

The result of the interval measurement  is displayed in the marker
measurements display bar.

See Also
To create a new value at measurement
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To create a new value at
measurement

Use the new value at measurement feature to measure the value of a bus or a single
signal at a specified marker location in data.  Measurement results are displayed in the
marker measurement display bar.

Note: Marker measurements use either the default M1 and M2 markers, or any other
user-defined markers.

1. From the menu bar select Markers>New Value At Measurement, or click the

 icon in the markers toolbar.

2. Select the numeric base of the data, the bus or signal source, then the
marker.

3. Click OK.

The result of the value at measurement   is displayed in the marker
measurement display bar.

See Also
To create a new interval measurement
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Trigger Functions
Timing mode trigger functions

State mode trigger functions

Timing mode trigger functions
The following trigger setup examples are available as Trigger Functions in the Advanced
Trigger dialog when in the timing acquisition mode.  To see these trigger setups in the
context of an example measurement refer to "Making a timing analyzer measurement".

Edge
� Edge

� "N" number of edges

� Edge and Pattern

� Edge followed by edge

� Edges too far apart

� Edge followed by pattern

� Pattern too late after edge

Bus Pattern
� Pattern

� Edge And Pattern

� Pattern present for > "T" time

� Pattern present for < "T" time

� Pattern absent for > "T" time

� Pattern absent for < "T" time

� Edge followed by pattern

� Pattern too late after edge

Other
� Find anything "N" times

� Reset and start timer

� Width violation on pattern or pulse

� Wait "T" seconds

� Run until user stop

� Wait for external arm

Advanced
� Advanced If/Then

� Advanced 2-Way Branch

� Advanced 3-Way Branch

� Advanced 4-Way Branch

� Pattern "AND" Pattern

� Pattern "OR" Pattern
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State mode trigger functions
The following trigger setup examples are available as Trigger Functions in the Advanced
Trigger dialog when in the state acquisition mode.  To see these trigger setups in the
context of an example measurement refer to "Making a state analyzer measurement".

Patterns
� Pattern "N" times

� "N" consecutive samples with Pattern1

� Pattern1 followed by Pattern2

� Pattern1 immediately followed by Pattern2

� Pattern1 followed by Pattern2 before Pattern3

� Too few states between Pattern1 and Pattern2

� Too many states between Pattern1 and Pattern2

� Pattern2 occurring too soon after Pattern1

� Pattern2 occurring too late after Pattern1

Other
� Reset and start timer

� Find anything "N" times

� Run until user stop

� Wait for external arm

� Wait "N" external clock states

Advanced
� Advanced If/Then

� Advanced 2-Way Branch

� Advanced 3-Way Branch

� Advanced 4-Way Branch

� Pattern AND Pattern

� Pattern OR Pattern

See Also
External Triggering
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Timing Mode

Timing mode trigger functions
Edge

� Edge

� "N" number of edges

� Edge and Pattern

� Edge followed by edge

� Edges too far apart

� Edge followed by pattern

� Pattern too late after edge

Bus Pattern
� Pattern

� Edge and Pattern

� Pattern present for > "T" time

� Pattern present for < "T" time

� Pattern absent for > "T" time

� Pattern absent for < "T" time

� Edge followed by pattern

� Pattern too late after edge

Other
� Find anything "N" times

� Reset and start timer

� Width violation on pattern or pulse

� Wait "T" seconds

� Run until user stop

� Wait for external arm

Advanced
� Advanced If/Then

� Advanced 2-Way Branch

� Advanced 3-Way Branch

� Advanced 4-Way Branch

� Pattern "AND" Pattern

� Pattern "OR" Pattern

See Also
State mode trigger functions

To build a trigger sequence

To store a trigger

To recall a trigger

Simple Trigger
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Edge

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a user-defined edge occurs.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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"N" number of edges

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when the "Nth" occurrence of a user-defined edge
occurs.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Edge followed by edge

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when edge 2 occurs within a specified time period
after edge 1.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Edge followed by pattern

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a bus pattern occurs within a specified time
period after an edge.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Edges too far apart

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when edge 2 does not occur within a specified
time period after edge 1.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a designated bus pattern occurs.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Edge and Pattern

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when both a user-defined edge and bus pattern
occur at the same time.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern present for > "T" time

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a user-defined bus pattern is present
greater than a specified time period.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern present for < "T" time

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a user-defined bus pattern is present less
than a specified time period.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern absent for > "T" time

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a user-defined bus pattern is absent greater
than a specified time period.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern absent for < "T" time

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a user-defined bus pattern is absent less
than a specified time period.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern too late after edge

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a specified bus pattern does not occur
within a specified time period after an edge.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern "AND" Pattern (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when both pattern1 "AND" pattern2 occur at the
same time, and for the specified numbers of samples (occurs).

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern "OR" Pattern (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when either pattern1 "OR" pattern2 occurs for the
specified numbers of samples (occurs).

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Find anything "N" times (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous. The analyzer triggers when it sees any data (Anything) for the Nth time.

To edit this function
To insert events and actions

To modify trigger setup display

To negate a function statement
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Width violation on pattern or pulse

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when a pulse or bus pattern is found that is either
too narrow or too wide.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Wait "T" seconds

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers after the specified time period expires.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Wait for external arm (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when an external arming signal appears through
the external trigger in port.  The external trigger port is located on the rear panel of the
168X models and the front panel of the 169X models.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Run until user stop (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.    This trigger function sets up to never trigger. You must select the stop
button to view the captured data.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Reset and start timer (timing)

Note: This trigger function is not available in the 1683A/93A models because they do
not have timers available.

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  This trigger function resets a timer, then starts the timer for a specified
period of time.  This trigger function requires that the timer value be set in either the
same trigger step, or another trigger step that follows.  When the timer stops, the
analyzer triggers.  For more information refer to "To configure a timer".

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced If/Then (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The analyzer triggers when the "If" clause becomes true.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced 2-Way Branch (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The two-way branch is evaluated true when either of two patterns (if or
Else if) are found.  Depending on which pattern is found true, the appropriate "Then"
action is executed.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced 3-Way Branch (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The three-way branch is evaluated true when either of three patterns
(If or Else if) are found.  Depending on which pattern is found true, the appropriate
"Then" action is executed.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced 4-Way Branch (timing)

This trigger function is available when the acquisition mode is set to Timing -
Asynchronous.  The four-way branch is evaluated true when either of four patterns (If
or Else if) are found.  Depending on which pattern is found true, the appropriate "Then"
action is executed.

To edit this function
To insert events and actions

To modify trigger step display

To negate a function statement
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State Mode

State mode trigger functions
Patterns

� Pattern "N" times

� "N" consecutive samples with Pattern1

� Pattern1 followed by Pattern2

� Pattern1 immediately followed by Pattern2

� Pattern1 followed by Pattern2 before Pattern3

� Too few states between Pattern1 and Pattern2

� Too many states between Pattern1 and Pattern2

� Pattern2 occurring too soon after Pattern1

� Pattern2 occurring too late after Pattern1

Other
� Reset and start timer

� Find anything "N" times

� Run until user stop

� Wait for external arm

� Wait "N" external clock states

Advanced
� Advanced If/Then

� Advanced 2-Way Branch

� Advanced 3-Way Branch

� Advanced 4-Way Branch

� Pattern "AND" Pattern

� Pattern "OR" Pattern

See Also
Timing mode trigger functions

To build a trigger sequence

To set store qualification

To store a trigger

To recall a trigger

Simple Trigger
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Pattern "N" times

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when it finds the nth occurrence of a bus
pattern as shown below.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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"N" consecutive samples with
Pattern1

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when a bus pattern occurs a specified
number times.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern1 followed by Pattern2

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern2 occurs eventually after
pattern 1.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern1 immediately followed by
Pattern2

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern 2 is found immediately after
exiting pattern 1.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern1 followed by Pattern2 before
Pattern3

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern2 occurs eventually after
pattern1, for a specified number of times, without pattern3 occurring in between.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement



90

Too few states between Pattern1 and
Pattern2

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern1 is followed by pattern2
with fewer than "N" specified states in between.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Too many states between Pattern1
and Pattern2

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern1 is followed by pattern2
with more than "N" specified states in between.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern2 occurring too soon after
Pattern1

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern2 occurs within a specified
time period after pattern1.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern2 occurring too late after
Pattern1

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when pattern2 does not occur within a
specified time period after pattern1.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Find anything "N" times (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous. It will trigger the logic analyzer when any data (Anything) is seen for the
Nth time.  It is commonly used to create an immediate trigger, or a trigger after a user-
defined delay.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Run until user stop (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  This trigger function sets up to never trigger. You must select the stop
button to view the captured data.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Reset and start timer (state)

Note: This trigger function is not available in the 1683A/93A models because they do
not have timers available.

This trigger function is available when the acquisition mode is set to State -
Synchronous.  This trigger function resets a timer, then starts the timer for a specified
period of time.  This trigger function requires that the timer value be set in either the
same trigger step, or another trigger step that follows.  When the timer stops, the
analyzer triggers.  For more information refer to "To configure a timer".

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Wait for external arm (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The analyzer triggers when an external arming signal appears through
the external trigger in port.  The external trigger port is located on the rear panel of the
168X models and the front panel of the 169X models.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Wait "N" external clock states

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The analyzer triggers on the "Nth" occurrence of the external clock signal
(plus any user-defined clock qualification) from the device under test.

 

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern "AND" Pattern (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The analyzer triggers when both pattern1 "AND" pattern2 occur at the
same time, and for the specified numbers of samples (occurs).

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Pattern "OR" Pattern (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The analyzer triggers when either pattern1 "OR" pattern2 occurs for the
specified numbers of samples (occurs).

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced If/Then (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The analyzer triggers when the "If" clause becomes true.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced 2-Way Branch (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The two-way branch is evaluated true when either of two patterns (if or
Else if) are found.  Depending on which pattern is found true, the appropriate "Then"
action is executed.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced 3-Way Branch (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.    The three-way branch is evaluated true when either of three patterns
(If or Else if) are found.  Depending on which pattern is found true, the appropriate
"Then" action is executed.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Advanced 4-Way Branch (state)

This trigger function is available when the acquisition mode is set to State -
Synchronous.  The four-way branch is evaluated true when either of four patterns (If or
Else if) are found.  Depending on which pattern is found true, the appropriate "Then"
action is executed.

To edit this function
To set store qualification

To insert events and actions

To modify trigger step display

To negate a function statement
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Task Guide
Listing display window

Waveform display window

Bus/Signal setup tab

Sampling setup tab

Triggering

Working with markers

File management

Symbols

Capturing Data

Searching

Printing

Importing

Exporting
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Waveform Window Tasks

Waveform Display Window

The Waveform window is accessed through the menu bar's Window>Waveform. If you
have Tabbed Windows turned on, you can also select a tab at the bottom of the window.

The Waveform window displays captured data as a digital waveform.  You can configure
the window to display selected buses and signals with time or pattern markers in the
data.  You can also set up bus pattern triggers and signal trigger options.

The Waveform window consists of the following four areas:

� Bus/Signal configuration

� Simple Trigger

� Marker display bar

� Waveform display area

Bus/Signal configuration
To access the following Bus/Signal configuration options, right-click on any bus or signal
name in the Bus/Signal column.

Undo - Undo the last action performed.

Insert Row Before - Inserts a predefined bus/signal before the highlighted row.

Insert Row After - Inserts a predefined bus/signal after the highlighted row.

Delete Row - Deletes the bus/signal in the highlighted row.

Expand - Expands the highlighted bus into separate displayed channels.

Collapse - Collapses displayed channels to a single displayed bus.

Assign Channels - Access to the Buses/Signals tab of the Analyzer Setup dialog for
mapping (assigning) the highlighted bus/signal to the desired pod and channel connection
of the probes.
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Rename - Access a keypad to rename the highlighted bus/signal.

Group into Bus - Groups highlighted signals into a bus.

Overlay - Overlays the highlighted bus or signal with another selected bus or signal.

Overlay Remove - Separates overlaid bus/signals.

Symbols - Access to edit symbols dialog for selected bus/signal.

Properties - Access to properties dialog for waveform window, waveform data, and
markers.

To reposition bus/signal names
To reposition bus/signal names in the display window, click and hold the mouse cursor
over the name to move, then drag and drop the name to the new position.  The name is
placed above the red position indicator that appears.

Simple Trigger
To set bus pattern triggers

To set signal trigger options

Marker display bar
To access the Marker bar options, right-click anywhere in the marker display bar.

New - To create new markers.

Place - To place markers in data.

Go To - Go To a predefined marker.

Center About - To center the display about a marker.

Delete - To delete a marker.

Rename - To rename a marker.

Send to back - To send a marker to the back.

Properties - To set marker properties.

Drag and drop markers - To move markers in the marker display bar.

Waveform display area
To access waveform display options, right-click anywhere in the display area.

Undo - Undo the last action performed.

Zoom Out

Zoom In

Go To

Place Markers

Center About Markers

Find

Find Next

Find Previous

Properties

Drawing Rectangle in data

Zoom In

Set Quick Trigger - Alternative way to set a Simple Trigger.

Find Next - Data value on left edge of rectangle becomes Find search criteria and next
occurrence of that data value is placed at center screen.
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Find Previous - Data value on left edge of rectangle becomes Find search criteria and
previous occurrence of that data value is placed at center screen.

Change Delay

Change Scale

See Also
Working with Markers

Advanced trigger dialog

To edit symbols

To add or delete display windows

Turning window tabs on/off

Tooltips
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Working with Markers
To create new markers

To place markers in data

Go To marker

To center the display about a marker

To delete a marker

To rename a marker

To send a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge

To create a new interval measurement

To create a new value at measurement

See Also
Markers display bar

Reading off-screen markers

Marker measurement display bar

Marker menu

Marker toolbar
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To set waveform window properties
Use the Waveform Properties dialog to modify the attributes of the waveform window or
the data that appears in each row of the display.  To access the Waveform Properties
dialog click Edit>Window Properties in the menu bar.

Tip:  You can also access the Properties dialog by a right-click in the display area,
then select Properties.

To set window properties
The following properties effect the entire waveform window, including displayed data,
bus/signal text, and simple trigger text.

To set background color

To set font size

To set an overlay color

To show activity indicators

To show tool tip - values

To show tool tip - transition width

To set markers - snap to edge

To set markers - move edge on screen

To set markers - place on edge

To set row properties
The following properties effect only the row data of the selected bus/signal unless <all>
is selected.

To select the Bus/Signal

To set data color

To set row height

To set numeric base

To show data values

To show soft glitch

To set bus options

To set background color
The background color property sets the background color of the data display area of the
waveform window.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click the background color box, then select the desired color from the palette.  If
you want to create a custom color, click Other... to access the custom color
dialog.

3. Click Ok.

To set font size
The font size property adjusts the size of font used in the data display, bus/signal text,
and simple trigger text.  Fonts can range from size 6 through 72.  As the font size is
changed, the row height is automatically adjusted to a minimum height to fit the new font
size.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click the font size up/down arrows to adjust the font to the desired size.
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3. Click Ok.

To set an overlay color
Multiple bus/signals can be inserted (Overlay) within a single row.  All overlaid
bus/signals are displayed in a different color than the primary bus or signal.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click the overlay color box, then select the desired color from the palette.  If you
want to create a custom color, click Other... to access the custom color dialog.

3. Click Ok.

To show activity indicators
Activity indicators are displayed to the left of the bus or signal name.  The Show Activity
Indicators property controls whether the indicators are shown or hidden.  The indicators
show either a low bar (low level), high bar (high level), or a transition arrow
(transitioning signal).

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Show Activity Indicators box to display the indicators.

3. Click Ok.

To show tool tip - values
When the mouse is moved within the display area, and is positioned directly over a
waveform, a tool tip (text readout) appears that displays the data value of that waveform
at its current position.  The Show Values property controls whether the tool tip is shown
or hidden.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Show Values box under Tool Tips.

3. Click Ok.

To show tool tip - transition width
When the mouse is positioned directly over a waveform, a tool tip (text readout) appears
that displays both the data value and the transition width of that waveform at its current
position.  The Transition Width property controls whether the tool tip includes the
transition width.  Transition width is displayed in parenthesis.

Note:  The Transition Width property is only available when Show Values is on.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Transition Width box under Tool Tips.

3. Click Ok.

To set markers - snap to edge
The Markers - Snap to Edge property enables easy placement of markers on waveform edges
by using graphical guidance.  When a marker is grabbed and dragged in the data display area,
the cursor changes to a green "direction arrow" indicating the direction of the next valid edge.
A red "valid edge" bar is placed on the next edge that the marker will be placed on if you
decide to release the mouse button.  In other words, the green arrow points to the red bar
where the marker will be placed.

If the mouse cursor is not positioned over any waveforms when you begin the drag and drop
operation, the marker can be dropped anywhere between edges with no snap-to-edge action.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Snap to Edge box under Markers.

3. Click Ok.

To set markers - move edge on screen
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When a marker is snapped to an edge that is off-screen, the data display is shifted so the
marker and the new edge it is snapped to, appear at center screen.  The waveform delay
is adjusted to the time of the new edge.

Note:  The Move Edge on Screen property is only available when Snap to Edge is on.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Move Edge on Screen box under Markers.

3. Click Ok.

To set markers - place on edge
With the Place on Edge property set, when a marker is placed using the right-click>Place
Marker shortcut, the marker will be placed on the closest edge from where the mouse right-
click occurred.  When the Place on Edge property is disabled, the marker is set where the
mouse right-click occurred.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Place on Edge box under Markers.

3. Click Ok.

To select the Bus/Signal
The Bus/Signal field lists all signals that have been inserted into the display in the
Buses/Signals tab. Use the Bus/Signal property to select the bus or signal that you want
the property changes applied to.  In addition to the individual signals listed, you also have
the selections of "all" and "selected".  The "all" selection will apply property changes to all
bus/signals.  The "selected" option is only available when multiple bus/signals are
selected (highlighted), and will apply property changes only to the bus/signals
highlighted, and only to the common properties to each of the selected bus/signals.  If a
property change is not valid to all selected bus/signals, the fields will be greyed out.

Property changes to a bus effects all signals within the bus.  For example, if the color of a
bus is changed, then if you were to expand the bus, all individual signals would have their
color changed.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click in the Bus/Signal name field, then select the desired bus/signal name.

3. Click Ok.

To set data color
The waveform Color property sets the color of the waveform in the data display.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click the color box, then select the desired color from the palette.  If you want
to create a custom color, click Other... to access the custom color dialog.

3. Click Ok.

To set row height
The Height property controls the height of the row measured in pixels.  The minimum row
height is set by the font size.  The maximum height is 1000 pixels.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click the Height box, then enter the desired height value.

3. Click Ok.

Tip:  You can also set row height by hovering mouse over separator line, when
cursor changes to a resizing cursor, click and drag row border to new width.

To set numeric base
The Base property sets the numeric base used to display the data.  If you change to a base
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that creates a longer number format (example; Hex to Binary), all fields are automatically
adjusted.  Also, if you have data values displayed within the waveform, and you switch from
Hex to Binary or Symbols, ">>" may appear to indicate that more text will be displayed if you
expand the scale.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Click the Base field, then select the desired numeric base.

3. Click Ok.

To show data values
The Show Value property enables an integrated display of both the waveform and the data
value of the waveform at that point.  You also can set a color for the waveform data value
text.

Note:  If the waveform time scale is small, ">>" may appear in the data value to
indicate that more text will be displayed if you expand the scale.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Show Value box, then click in the color box and select the desired
color from the palette.  If you want to create a custom color, click Other... to
access the custom color dialog.

3. Click Ok.

To show soft glitch
The Show Soft Glitch property enables you to be visually cued when multiple transitions
are occurring at the same point in time.  It does this by displaying screen pixels that are
common to multiple transitions being drawn on screen.  These common pixels are drawn
in a different color to create an eye pattern to compare against an expected visual
pattern.  Soft glitches are seen when you zoom out the time scale.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Show Soft Glitch box, then click in the color box and select the
desired color from the palette.  If you want to create a custom color, click
Other... to access the custom color dialog.

3. Click Ok.

To set bus options
The Bus Options button is only available when a bus is selected for property changes. The
options listed below are applied only to the selected bus.

1. From the Waveform Properties dialog, click the Windows Properties tab.

2. Check the Show Value box, then click in the color box and select the desired
color from the palette.  If you want to create a custom color, click Other... to
access the custom color dialog.

3. Click Ok.

To set waveform style - Bus
The Bus property sets the waveform appearance to a conventional bus shape.  When Bus
is selected, and MSB ordering is checked, the ordering of the signals in the bus are
changed from least significant bit first to most significant bit first.

To set waveform style - Magnitude
The Magnitude property sets the waveform appearance to a samples versus time (chart
mode) display.  When Magnitude is selected, and Show Axis is checked, a small axis is
drawn in the center of the waveform which represents the center of the range of values
being displayed.  When Show Axis is checked, you can also set an axis color.

When the Magnitude property is selected, you can also set the following Waveform
Limits:
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� Max/Min - sets the range limits of the displayed axis.

� Lock to Setup - sets the range limits based on the width of the bus.  For example,
an 8-bit bus is set to a range of 0-255.

� Show Clipped - enables out-of-range data values to be displayed in a user defined
color.

To expand into signals
The Expand into Signals property expands the bus into individual signals.  This function is the
same as if you selected the Expand (+) field to the left of the bus name.

See Also
To set marker properties
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Change delay

The delay adjusts the display window relative to the waveform data.  The display
window's relative position in time is dependant on the trigger point, and the beginning
and end of data. Use the following delay controls to position the display window over the
desired data.

Use the keypad to enter a numeric value.  If the value you enter is greater than or
less than the time of the data range, the window will be moved to the beginning
or end limit.

Moves the window over the beginning of data.

Scrolls the window towards the beginning of data.

Moves the window over the trigger point.

Scrolls the window towards the end of data.

Moves the window over the end of data.



116

Change scale (time/division)
Data from a timing analyzer is displayed similar to oscilloscope data.  That is,  they both
display waveforms on a horizontal time axis.  Therefor, to zoom in or out on a waveform,
you simply change the Scale (time/division) of the time axis that the waveform is viewed
with.

� Change the scale

� Draw a rectangle in the data

Change the scale
1. Click the zoom out icon to expand the signals to where you want them.  The scale

ranges from 1 ps/div to 1ks/div.  You can also change the scale by clicking the
keypad icon and entering a numeric value.

Draw a rectangle in the data
1. Point the mouse to the upper-left corner of the desired view area, then click and

hold while moving the mouse to the lower-right corner, then release the mouse
button.

2. Select Zoom In.  The new display scale is adjusted to the width of the box
drawn.
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To overlay bus/signals
Use the Overlay feature to place multiple bus or signals into one row of displayed data.
When multiple signals are overlaid, you can see the relationships visually between all
signals.  The overlaid bus or signal is drawn first, then the main bus/signal is drawn last
as to overwrite the overlaid bus/signals for clarity.

1. Right-click on the bus or signal you want to overlay another bus or signal onto,
then select Overlay... .

2. From the Overlay selection dialog that appears, select the bus or signal you want
to overlay onto the highlighted bus or signal.

3. If you want to change the color of the overlaid bus or signal, go to Window
Properties and change Overlay color.
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To group signals into a bus
1. While holding the shift key down, click on all desired signals.

2. With the mouse pointer over any one of the highlighted signals, right-click and
select Group into Bus.
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To add or delete display windows
You can add new listing and waveform display windows to the interface.  As new windows
are added, they appear in the list under Window in the menu bar.  The active window
will have a check mark.  All available windows can be accessed either through the menu
bar or through the use of tabs.

To add a new display windows
1. In the menu bar, click Window>New Listing or New Waveform.  If the

windows are tabbed, you can also right-click on the tab, then select New Listing
or New Waveform.

To delete display windows
1. From the menu bar, click Window>Close.  If windows are tabbed, you can also

right-click on the tap, then select Close.

See Also
Turning window tabs on/off

Viewer toolbar
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Turning window tabs on/off
By default, the Listing and Waveform display windows are tabbed for ease of switching
between displays.

To turn on or off window tabs, select View>Tabbed Windows.

To switch display windows when tabs are turned off, you must select Window>"display
window name".

See Also
To add or delete display windows
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Set quick trigger with rectangle
Within the waveform and listing displays, you can quickly setup a simple trigger by
drawing a rectangle with the mouse.  After a simple trigger has been defined, and the
analyzer is run, the trigger is stored and can be recalled at any time.

The following guidelines explain how each display interprets the drawn rectangle in
regards to the data and how the trigger is set.

General guidelines:

� Any bus/signals with overlapping bits are not included within the trigger
specification.

Example: Bus_1 has channels 0 through 7 of pod 1 assigned and  Bus_2 has
channels 3 through 6 of pod 1 assigned.  At this point, you have the same probed
signals (channels 3 through 6 of pod 1) assigned in both Bus_1 and Bus_2.  Now
you draw the rectangle over both bus_1 and bus_2.  Since Bus_1 channels 3
through 6 are repeated (overlapped) on  Bus_2, they will not be included in the
trigger specification.

� Only a single sequence level can be defined by a drawn rectangle.

� As you draw the rectangle, a tooltip is displayed showing the current trigger
specification that would be set.

Specific guidelines to the listing display:

� As you move the mouse left-to-right and top-to-bottom, the signal level or bus
value in contact with the top of the rectangle becomes the trigger.

Specific guidelines to the waveform display:

� As you move the mouse left-to-right and top-to-bottom, the signal edge/level or
bus value in contact with the left of the rectangle becomes the trigger.

� Only one edge can be set.

� If a bus is expanded into its separate signals, three condition apply: 1.  If drawing
starts on a bus, none of its expanded signals can be included. 2.  If drawing starts
on a signal, the bus cannot be included. 3.  Edges and levels are mutually
exclusive.  That is, either one edge can be set, or all levels can be set, but not
both at the same time.

To draw the rectangle
1. Using the mouse, point to the upper-left corner of your desired trigger rectangle.

2. While holding down the mouse button, drag the mouse pointer to the lower-right
corner of your desired rectangle, then release the mouse button.  As you draw
the rectangle, you can monitor the trigger as it is set with the tooltip readout that
appears.
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Note: In the waveform display, it may be necessary to redraw the rectangle if
you do not get your desired trigger points dictated by the left-side line of the
rectangle.  You could also try drawing the rectangle backwards leaving the left-side
rectangle line set last.

3. Select Set Trigger.

.
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Tool Tips
Tool tips are small information displays (text readout) that appear during mouse
operations such as hovering over a waveform or bus/signal name, moving markers, or
drawing a rectangle in data.  Use them as comments or to read current positions,
waveform transition widths, or trigger specifications (when setting trigger with mouse).
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To add user comments

You can attach comments to buses and signals.  The comments show up in the tool tip
when you hover the mouse over a bus or signal name in both the waveform and listing
windows.

1. From the menu bar, select Setup>Bus/Signal.

2. In the Buses/Signals setup tab that appears, select Display.

3. Select Comment.  A new column labelled Comment appears.

4. In the Comment column, type your comment for the bus or signal.

5. Click OK to close the Analyzer Setup dialog.

Note:  Comments are intended as a descriptor to embellish a bus/signal name and not
as a notepad.  Comments can be up to 64 character in length.
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To edit symbols for a bus/signal
You can edit symbols whenever the Edit symbols dialog is displayed.

To add a symbol
1. Select Setup>Symbols....

2. Select the bus or signal for which the new symbol should be displayed.

Each symbol is defined for a particular bus/signal.

3. Click Add.

4. Define a value or range of
values.

There are no restrictions on the characters you can use in the name of a symbol.
The symbols on a particular bus or signal must have unique names.

5. Click Apply.

To see the symbols in the listing or waveform display, click OK in the Symbols dialog and
change the base for the bus/signal to Symbols.

To edit a symbol
1. Select Setup>Symbols....

2. Select the symbol you want to edit.

3. Click Edit.

To delete a symbol
1. Select Setup>Symbols....

2. Select the symbol you want to delete.

3. Click Delete.

To save symbols
Save symbols as part of a configuration file. Symbols are saved in the configuration
whether or not you select Setup only in the Save As dialog.
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See Also
To display symbols
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Listing Window Tasks

Listing Display Window

The Listing window is accessed through the menu bar's Window>Listing. If you have
Tabbed Windows turned on, you can also select a tab at the bottom of the window.

The Listing window displays your captured data as a state listing.  You configure the
window to display selected buses and signals in columns.  Within the listed data, you can
insert time or pattern markers.  You can also configure the bus pattern triggers and
signal trigger options.

The Listing window consists of the following four areas:

� Column configuration

� Simple Trigger

� Marker display bar

� Listing display area

Column configuration
To access the following column configuration options, right-click on any bus or signal
name in the column head.

Insert Column Before

Insert Column After

Delete Column

Assign Channels

Rename

Symbols

Display

Properties
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To reposition bus/signal names
To reposition bus/signal names in the display window, click and hold the mouse cursor
over the name to move, then drag and drop the name to the new position.  The name is
placed to the left of the red position indicator that appears.

Simple Trigger
To set bus pattern triggers

To set signal trigger options

Marker display bar
To access the marker display options, right-click anywhere in the marker display bar.

New - To create new markers.

Place - To place markers in data.

Go To - Go To a marker.

Center About - To center the display about a marker.

Delete - To delete a marker.

Rename - To rename a marker.

Send to back - To send a marker to the back.

Properties - To set marker properties.

Drag and drop markers - To move markers in the marker display bar.

Listing display area
To access the Listing display options, right-click anywhere in the display area.

Undo - Same as Edit>Undo.

Go To

Place Marker

Find

Find Next

Find Previous

Properties

Draw Rectangle in data

Set Quick Trigger - Alternative way to set a simple trigger.

Find Next - Data value on top edge of rectangle becomes Find search criteria and next
occurrence of that data value is placed at center screen.

Find Previous - Data value on top edge of rectangle becomes Find search criteria and
previous occurrence of that data value is placed at center screen.

Copy Text - Copies data as text into the system clipboard.

See Also
To display symbols

Working with Markers

To add or delete display windows

Turning window tabs on/off

Tool Tips
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Column configuration
To access the tasks in this area, right-click on any bus or signal name in the column head
of the listing window.

Insert Column Before

Insert Column After

Delete Column

Assign Channels

Rename

Symbols

Display

Properties

Insert Column Before
Accesses a list of predefined bus and signal names.  The selected name is inserted to the left
of the highlighted column. To create new bus and signal names go to To add a new bus or
signal.

Insert Column After
Accesses a list of predefined bus and signal names.  The selected name is inserted to the right
of the highlighted column.  To create new bus and signal names go to To add a new bus or
signal.

Delete Column
Deletes the highlighted column.

Assign Channels
To assign channels to pods go to Buses/Signal Setup.

Rename
Accesses a keypad to rename the highlighted bus or signal name.

Symbols
For information on editing symbols, go to Symbols.

Display
Turns on or off the activity indicators, default base, and the simple trigger.  When turned on,
they are visible in the column head of the listing window.

Properties
For information on setting listing window properties, refer to To set listing window
properties.
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To set listing window properties
Use the Listing Properties dialog to modify the attributes of the listing window or the data
that appears in each column of the display.  To access the Listing Properties dialog click
Edit>Window Properties from the menu bar.

Tip:  You can also access the Properties dialog by a right-click in the display area,
then select Properties.

To set window properties
The following properties effect the window as well as all displayed row data.

To set background color

To set font size

To show column display options - activity indicators

To show column display options - column base

To show column display options - simple trigger

To show center rectangle

To set column properties
The following properties effect the displayed column data.

To select the Bus/Signal name

To set data color

To set column width

To set column alignment

To set numeric base

To set marker relative

To set background color
The Background Color property sets the background color of the data display area of the
Listing window.

1. From the Listing Properties dialog, click the Windows Properties tab.

2. Click the background color box, then select the desired color from the palette.  If
you want to create a custom color, click Other... to access the custom color
dialog.

3. Click Ok.

To set font size
The font size property adjusts the size of font used in the data display, bus/signal text,
and simple trigger text.  Fonts can range from size 6 through 72.  As the font size is
changed, the column width is automatically adjusted to a minimum width to fit the new
font size.

1. From the Listing Properties dialog, click the Windows Properties tab.

2. Click the font size up/down arrows to adjust the font to the desired size.

3. Click Ok.

Column display options
The Column Display Options properties enable viewing of the activity indicators, the column
base, and the simple trigger configuration.

Display activity indicators
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Activity indicators are displayed to the left of the bus or signal name.  The indicators
show signal activity as either a low bar (low level), high bar (high level), or a transition
arrow (transitioning signal).

1. From the Listing Properties dialog, click the Windows Properties tab.

2. Check the Display Activity Indicators box to display the indicators.

3. Click Ok.

Display column base
The base field displays the numeric base for which the data is displayed in.  The numeric base
is set in the Buses/Signals tab of the Analyzer.

1. From the Listing Properties dialog, click the Windows Properties tab.

2. Check the Display Column Base box to display the indicators.

3. Click Ok.

 Display simple trigger
The Display Simple Trigger property enables configuration and viewing of the simple trigger.
For more information on configuring the simple trigger refer to Simple Trigger.

1. From the Listing Properties dialog, click the Windows Properties tab.

2. Check the Display Simple Trigger box to display the indicators.

3. Click Ok.

To show center rectangle
The center rectangle is the box that is drawn around the one state displayed at center screen.
The Display Rectangle property enables the rectangle to be displayed or hidden.

1. From the Listing Properties dialog, click the Windows Properties tab.

2. Under Center Rectangle, check the Display Rectangle box to display the center
rectangle.

3. Click the rectangle color box, then select the desired color from the palette.  If
you want to create a custom color, click Other... to access the custom color
dialog.

4. Click Ok.

To select the Bus/Signal name
The Bus/Signal field lists all signals inserted into the display. The names are listed in the
same order as they appear in the display.  Use the Bus/Signal property to select the bus
or signal that you want the property changes applied to.  In addition to the individual
signals listed, you also have the selections of "all" and "selected".  The "all" selection will
apply property changes to all bus/signals.  The "selected" option is only available when
multiple bus/signals are selected (highlighted in display), and will apply property changes
only to the bus/signals highlighted, and only to the common properties to each of the
selected bus/signals.  If a property change is not valid to all selected bus/signals, the
fields will be greyed out.

Property changes to a bus effects all signals within the bus.  For example, if the color of a
bus is changed, then if you were to expand the bus, all individual signals would have their
color changed.

1. From the Listing Properties dialog, click the Column Properties tab.

2. Click in the Bus/Signal name field, then select the desired bus/signal name.

3. Click Ok.

To set data color
The Color property sets the color of the data in the listing display.

1. From the Listing Properties dialog, click the Column Properties tab.
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2. Click the color box, then select the desired color from the palette.  If you want
to create a custom color, click Other... to access the custom color dialog.

3. Click Ok.

To set column width
The Width property controls the width of the column (specified in pixels).  The minimum
column width is 1 pixel, while the maximum width is 1000 pixels.

1. From the Listing Properties dialog, click the Column Properties tab.

2. Click the width box, then type in the desired pixel width value.

3. Click Ok.

Tip:  You can also set column width by hovering mouse over separator line, when
cursor changes to a resizing cursor, click and drag column border to new width.

To set column alignment
The Alignment property sets the display of data to be left-justified, right-justified, or
centered within the column.

1. From the Listing Properties dialog, click the Column Properties tab.

2. Click the Alignment box, then select the desired alignment choice.

3. Click Ok.

To set numeric base
The Base property sets the numeric base used to display the data.  If you change to a
base that creates a longer number format (example; Hex to Binary), all fields are
automatically adjusted.

1. From the Listing Properties dialog, click the Column Properties tab.

2. Click the Base box, then select the desired numeric base choice.

Note:  If the Time column has been selected instead of a data column, your
choices change from a numeric format to Absolute, Relative Previous, or Relative
Marker.

3. Click Ok.

To set marker relative
The Marker property only applies when a Time column is selected and the base of the
Time column is set to Relative Marker.  This field allows the selection of a marker to act
as the location where time should be relative from.

1. From the Listing Properties dialog, click the Column Properties tab.

2. Click the Marker box, then select the desired marker.

3. Click Ok.

See Also
To set marker properties
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To display symbols
You can display a bus or signal using meaningful names rather than numeric values.

Symbols can be displayed in both the Listing and Waveform displays.

To display symbols:

1. Change the numeric base of the bus or signal to Symbols.

2. Define the symbols.

If the symbol is defined as a range, values in the range will be displayed with an offset
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from the lowest end of the range.

If the definitions of several symbols overlap, the first one listed in the Symbols dialog has
precedence over the others.

In the Waveform display, ">>" will be shown when the full name of the symbol will not fit
into the space available.

Once you have set up symbols, it's usually a good idea to save the logic analyzer
configuration. The symbol definitions will be stored as part of the configuration.

Example
Here is what "My Bus 1" looks like before defining any symbols:

When the symbols have been defined, they are shown in the Symbols dialog:

Here is what the bus looks like after the symbols are defined:
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Buses/Signals Setup Tasks

Buses/Signals Setup

The Buses/Signals tab is accessed through the menu bar's Setup>Bus/Signal.  The
Buses/Signals tab is used to map (assign) bus and signal names in the interface to the
pod and channel connections of the probes.  You also use the Buses/Signal tab to setup
thresholds, polarity, numeric base, and enter user comments.  Through the Display...
field, you can select what bus/signal setup information is displayed.

The following tasks are performed in the Buses/Signals setup tab.

To add a new bus or signal

To delete a bus or signal

To rename a bus or signal

To assign channels

To set thresholds

To set numeric base

To set setup/hold

To set polarity

To add user comments

To add a folder

To alias a bus/signal name

To edit symbols

Read only options
The following fields are read only and cannot be edited.  The display of these items can
be turned on/off under the Display... field.

Channels Assigned The Channels Assigned column displays the
channel assignments in textual form.

Width The Width column displays the number of
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assigned channels on each bus.

Activity The Activity row displays the type of signal
activity on each channel.

� Low bar = A stable low level.

� High bar = A stable high level.

� Transition arrows = An active signal
transition between low and high

Channel Numbers The Channel Numbers row displays pod
channel numbers
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To add a new bus or signal
The add bus/signal feature allows you to add new buses and signals to the configuration.
Once added to the configuration, the new bus/signal is automatically inserted into the
data displays and also becomes available in any bus/signal insert function.

1. From the menu bar, select Setup>Bus/Signal.

2. Select Add Bus/Signal to add a new bus or signal.

3. The new bus/signal will appear with a system generated default name.  Rename
the new bus/signal if desired.

Note:  Before a new bus/signal can be added to the configuration, at least one channel
must be assigned to the bus/signal.

See Also
To delete a bus or signal

To rename a bus or signal

To assign channels

Buses/Signals Setup
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To delete a bus or signal
The delete bus or signal feature allows you to remove buses and signals individually or all
at once.  The delete bus or signal feature is accessed through the setup menu or the
setup toolbar.

To delete an individual bus or signal

To delete all buses and signals

To delete an individual bus or signal
1. From the menu bar, select Setup>Bus/Signal.

2. Highlight the bus or signal you want to delete.

3. Click
Delete.

To delete all buses and signals
1. From the menu bar, select Setup>Bus/Signal.

2. Click Delete All.

Note:  Some tools "lock" buses and signals because they use the bus or signal to
produce their own output.  Delete and Delete All will not delete these locked buses and
signals.  A locked bus or signal has a grey icon to the left of the name instead of a red
icon.

See Also
Buses/Signals Setup
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To rename a bus or signal
The rename bus/signal feature allows you to change bus and signal names.  All channel,
pod, and clock assignments for the renamed bus/signal remain unchanged.

1. From the menu bar, select Setup>Bus/Signal, or click the  icon in the
setup toolbar.

2. Right-click the bus or signal name and choose Rename...

3. Enter the new bus or signal name.

4. Select OK.

 See Also
To add a new bus or signal

To delete a bus or signal

Buses/Signals Setup
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To assign channels
To make the logic analyzer display match your system's design, assign the physical
channels of the logic analyzer to bus and signal names.

1. From the menu bar, select Setup>Bus/Signal.

2. In the Buses/Signals tab, select squares in the grid to assign channels to bus and
signal names.  For each signal probed in your device under test, you should have
a black check mark mapping the channel to a pod and to a signal name in the
interface.   Example: In the picture below, channels 0-7 (pod 1) are mapped to
My Bus 1, channels 8-15 (pod 1) are mapped to My Bus 2, and channels 8 and 9
(pod 2) are mapped to My Signal 1 & 2 respectively.

Tip: If clock channels are not connected to clock signals, they can be used as extra data
channels.  Clock channels are grouped together after the last pod in the channel
assignment area.
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To set thresholds
It is very important that you specify a threshold voltage that matches what your target
system is using.  Incorrect threshold voltages result in incorrect data.

1. From the menu bar, select Setup>Bus/Signal.

2. Click any Threshold field.  The Threshold fields are located under the Pod label.

The Threshold Settings window appears.

a. Select All Pods or just a single pod.

b. Specify the threshold level.  Choices are

AGP  (1.32 V) CCT (1.50 V) CMOS 5V (2.50 V)

ECL (-1.30 V) GTL (0.80 V) GTLPlus (1.00 V)

HSTL (0.75 V) LVCMOS 1.5V (0.75V) LVCMOS 1.8V (0.90 V)

LVCMOS 2.5 V (1.25 V) LVCMOS 3.3 V (1.65 V) LVPECL (2.00 V)

LVTTL (1.40 V) PECL (3.70 V) SSTL2 (1.25 V)

SSTL3 (1.50 V) TTL (1.50 V) User (-6.00 to 6.00 V)
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To set numeric base
You can set the default numeric base for a bus when you create the bus.  The default
base is used to display bus and signal values in the listing and waveform views.   Default
base only affects new buses and signals; if you change default base for an existing bus or
signal you will not see a change unless you add a new copy of the bus or signal to a
listing or waveform view.

1. From the menu bar, select Setup>Bus/Signal.

2. In the bus/signal setup dialog, select Display.

3. Select Default
Base.

4. To change the default base for a bus or signal, click the default base value.
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5. Select a new value.

6. Click OK to close the bus/signal dialog.
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To set polarity
You can define buses and signals to display with negative or positive polarity.  This affects
the display of values and waveforms.  When a bus or signal is set to negative polarity, an
incoming high voltage will be shown with a low waveform and a logical value of 0.  The
polarity is reflected in all places that use values, such as trigger and symbols.

The default polarity is positive (high = 1).

1. From the menu bar, select Setup>Bus/Signal.

2. In the bus/signal setup dialog, select Display.

3. Select
Polarity.

4. In the polarity column that appears, toggle between + (positive) and  (negative).



146

To set setup/hold
Setup and hold is available in State mode only.

Setup/Hold specifies where the logic analyzer's window should be relative to the clock
signal it receives from the target system.  The target system needs a window in which the
data is valid that is at least as long as the logic analyzer's setup/hold window plus any
clock offset.  Use the setup/hold setting to move the logic analyzer's setup/hold window
relative to the target system's data valid window.

1. Select Setup>Timing/State (Sampling)...

2. Change Acquisition to State - Synchronous Sampling.

3. Set up the clock description.

Note:  Single-edge clocks have a smaller setup/hold window than other clocks.
Changing to a different setup/hold window changes the setup value.  (Hold remains
constant.)

4. Select Buses/Signals
tab.

5. If the Setup/Hold column is not already displayed, select Display>Setup/Hold.

6. If you are using a slave or demultiplexed clock, change the pod clock type for
appropriate buses and signals.  You change the pod clock type by selecting
Master Clock in the pod column of the assigned channels.

7. Click the bus or signal's Setup/Hold value to adjust it.  You can also adjust
individual bits, in which case the field shows Individual.

If the data valid window on the target system does not include the time when the clock
signal transition, use negative values for the setup or hold.  For a single-edge clock, the
valid setup/hold window is adjustable from 4.5 ns setup/-2.0 ns hold to -2.0 ns setup/4.5
ns hold in 100 ps increments.  For multiple-edge clocks, the valid setup/hold window is
adjustable from 5.0 ns setup/-2.0 ns hold to -1.5 ns setup/4.5 ns hold in 100 ps
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increments.

Note: Setup time cannot be changed independently of hold time.  The total setup/hold
window is a constant, but can be adjusted relative to your data valid window.

See Also
To select the state clock type

To set the state clock qualifier
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To add a folder
The Add Folder... feature adds a windows style folder to the bus/signal list.  Use folders
to help organize bus and signal names when using many bus/signal names with inverse
assemblers.

1. From the menu bar, select Setup>Bus/Signal.

2. Right-click on a bus/signal name, then select Add Folder.

3. The new folder appears directly below the highlighted name.  By default, the new
folder has a system generated default name.  If desired, rename the new folder in
the same way you would a bus/signal name.

See Also
To alias a bus/signal name
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To alias a bus/signal name
The Add Alias... feature adds an exact duplicate bus or signal name (same channel,
polarity, etc. assignments).  Use alias names along with folders to help organize the
many bus and signal names with inverse assembly.

1. From the menu bar, select Setup>Bus/Signal.

2. Right-click on the desired bus/signal name, then select Add Alias.

3. The new alias name appears directly below the highlighted name.  The  new alias
name can be renamed, however, the new name will also be applied to the original
name.

See Also
To add a folder
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Sampling Setup Tasks

Sampling Setup

The Sampling tab is access through the menu bar's Setup>Timing/State (Sampling).
The Sampling setup tab is used to select and configure the acquisition mode.

In the Timing - Asynchronous Sampling mode, you set the sampling period and channel
width.  You also set the acquisition (memory) depth and the trigger position.   Timing
mode samples the target system at regular intervals (the sampling period).

In the State - Synchronous Sampling mode, you configure the clocking type and any
desired clock qualifier.  You also set the acquisition (memory) depth and the trigger
position.  State mode samples the target system when a signal matching the defined
clock occurs.

The following tasks are performed in the Sampling setup tab.

To set the acquisition mode

To set acquisition depth

To set the trigger position

State - Synchronous Sampling mode
To select the state clock type

To set the state clock qualifier

To setup advanced clocking

Timing - Asynchronous Sampling mode
To set the sampling period
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To set the sampling options
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To set the acquisition mode
To select the timing analyzer

1. From the menu bar select Setup>Timing/State (Sampling), or click the 
icon from the setup toolbar.

2. In the Sampling setup dialog, select the Timing - Asynchronous Sampling
option.

To select the state analyzer

1. From the menu bar select Setup>Timing/State (Sampling), or click the 
icon from the setup toolbar.

2. In the Sampling setup dialog, select the State - Synchronous Sampling option.



153

To set acquisition depth
The acquisition depth control allows the user to set the amount of memory that is filled
with data on an acquisition. The choices available depend on the maximum memory
depth available in the analyzer that is being used.

1. From the menu bar select Setup>Timing/State (Sampling).

2. Set the acquisition mode and any state or timing options.  These will affect the
available memory choices.

3. In the Options box to the right, set Acquisition Depth.

See Also
To set the trigger position
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To set the trigger position
The trigger position specifies the amount of trace memory used for samples captured
before the trigger.  For example when 10% is selected, 90% of trace memory is used for
samples captured after the trigger.  When 90% is selected, 10 % of trace memory is used
for samples captured before the trigger.

In timing mode, the amount of pre-trigger and post-trigger memory will always be what
you expect based on your settings, even if your trigger condition occurs before pre-
trigger memory is filled. This is happens because in timing mode, the trigger sequencer
does not start until pre-trigger memory is full.

However, this is not true for state mode. In state mode, the sequencer starts
immediately, in other words, it doesn't wait for prestore memory to be filled. Thus, in
state mode, your trigger position may not be where you expect. For example, if you set
the trigger position to 50%, but you find the trigger right away, the amount of pre-trigger
memory will be less than what you expect.

1. From the menu bar select Setup>Timing/State (Sampling), or click the 
icon from the setup toolbar.

2. Select the trigger position.

See Also
To set the acquisition depth
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To select the state clock type

By default the clock mode is set to Master.  If you want to set the clock mode to Master/Slave
or Demultiplex, follow the procedure below.

Note: To probe demultiplexed data, use only one pod of a pod pair.

1. From the menu bar, select Setup>State/Timing (Sampling).

2. Select State.

3. In the State Options, change Clock Mode to Master/Slave/Demux.

4. Set up your master and slave clocks.

5. Select the Buses/Signals tab.

6. Select the Clock field under the pod heading.

7. For Demultiplex mode: Set the clock to Demultiplex.  The display of the pod
and its neighbor changes.  For example, if you set Pod 1 to demultiplex, Pod 2 goes away and
you see two Pod 1 columns.  The first Pod 1 column is labelled Pod 1 (Master Clock) and the

second column is Pod 1 (Slave Clock). For Master/Slave mode: Change pod
clock fields to Slave as necessary.

8. Assign channels to buses.

Master
In the Master only sampling clock mode, there is one sampling clock signal. When a clock
edge occurs, data is captured and saved into one sample of logic analyzer memory. Two
additional sampling clock modes let you capture data differently:

Master/Slave
In the Master/Slave mode, you can save data captured on different clock edges into the
same sample of logic analyzer memory.
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When the slave clock occurs, data captured on the pods that use the slave clock is saved
in a slave latch. Then, when the master clock occurs, data captured on the pods that use
the master clock, as well as the slave latch data, are saved into logic analyzer memory.
If multiple slave clocks occur before the next master clock, only the most recently
acquired slave data is saved into logic analyzer memory.

Demultiplex
In the Demultiplex mode, you can demultiplex data being probed by one pod into the
logic analyzer memory that is normally used for two pods.   Demultiplex mode uses the
master and slave clocks to demultiplex the data.

When the slave clock occurs, data captured on the pod is saved into the slave latch for the
other pod in the pod pair. Then, when the master clock occurs, data captured on the pod, as
well as the slave latch data, are saved in logic analyzer memory.  As with master/slave mode,
if multiple slave clocks occur before the next master clock, only the most recently acquired
slave data is saved into logic analyzer memory.

See Also
To set the state clock qualifier

To setup advanced clocking
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To set the state clock qualifier
The state clock should be set to match the clock signal on your target system.  The logic
analyzer can handle clock signals comprised of up to four lines.  Clocks can be as simple
as a single rising edge, or a complicated combination of edges and highs or lows.

In the picture above, the clocks refer to the clock signal lines on pods 1 through 4.
Depending on model, your logic analyzer may have more pods.  However, only the clock
lines on the first 4 pods can be used to generate the state clock signal.  Clock lines on
extra pods can be used like normal data lines.

1. Attach logic analyzer pods to your target system.  Clock signals must be
connected to the clock lines on pods 1 through 4.

2. From the menu bar, select Setup>Timing/State (Sampling).

3. Select State - Synchronous Sampling.  The State Options area becomes active.

4. Select the state clock type.  Most measurements use only the master clock.

5. Set up a clock description to match the clock(s) on your target system.

Don't care.  Clock line not used in this clock.

Rising edge.

Falling edge.

Either edge.

Qualifier - high.

Qualifier - low.

A clock description must have at least one edge.

See Also
To select the state clock type

To set setup/hold

To setup advanced clocking
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To set up advanced clocking
The Advanced Clocking dialog lets you specify more complex clock setups than you can
with the normal Master or Slave selections.  If you want to use a specific clock channel
both as an edge and a qualifier in the same clock description, you need to use advanced
clocking.

1. From the menu bar, select Setup>State/Timing (Sampling).

2. Select State mode.  The state options become selectable.

3. Next to the clock mode, select Advanced Clocking.  The clock controls are
replaced by a button.

4. Select Master Clock... or Slave Clock... as appropriate.  The Advanced Clocking
Setup dialog appears.

5. Choose settings as appropriate.  Clock channels can be used both as primary
clocking and as clock qualifiers.

6. Click OK to close the dialog.  The clock description in the Analyzer Setup window
updates.

Note: If you un-check advanced clocking, the clock settings are preserved except that
all qualifiers are erased.
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To set the sampling period
In timing mode, a logic analyzer takes a sample of the target system's activity once per
sample period.  You can set this sample period in the Sampling Setup tab.  When running
in 800 MHz mode, the sample period is not changeable.

1. From the menu bar select Setup>Timing/State (Sampling), or click the 
icon from the setup toolbar.

2. Select Timing - Asynchronous Sampling.

3. In the Timing Mode area of the Sampling setup dialog, increase or decrease the
Sample Period.

Note:  To capture signal level changes reliably, the sample period should be less
than half of the period of the fastest signal you want to measure.  Time interval
measurements are made by counting the number of samples in the desired
waveform area.  These measurements are made to a +/- one sample error, so
measurement accuracy is improved if the number of samples is maximized.
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To set sampling options
In Timing (asynchronous) mode, you can trade off channel width for increased sample
time.  That is, if you want a faster sampling period, you can choose the option of using
only half of the maximum channels available for your analyzer model.  The channel count
will vary according to the analyzer model you have.

� 1680A/90A - 136 channels

� 1681A/91A - 102 channels

� 1682A/92A - 68 channels

� 1683A/93A - 34 channels

1. From the menu bar, select Setup>State/Timing (Sampling).

2. Select Timing acquisition mode.  Timing Options becomes selectable.

3. Select the sampling option you prefer.  Your channel count may be different
depending on the logic analyzer model.

Note: Changing the sampling option will affect the sampling period and may affect bus
assignments.

136 channels, 400 MHz Default.  All channels are available; the sampling
period can be set from 2.5 ns to 1 ms.

68 channels, 800 MHz Uses one pod from each pod pair.  The sampling
period is always 1.25 ns.

Store transitions only, 136 channels,
200 MHz

Provides maximum duration of acquisition
because data is only stored when a change from
the last value is detected.  Sampling period
ranges from 5.0 ns to 1 ms.  See transitional
timing.

See Also
Transitional timing
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Transitional timing
In the Store transitions only mode, the timing analyzer samples data at regular
intervals, but only stores data when there is a threshold level transition. Each time a level
transition occurs on any of the bits, data on all channels is stored. A time tag is stored
with each stored data sample so the measurement can be reconstructed and displayed
later.

More on storing transitions
Minimum transitions stored
Normally, transitions do not occurred at each sample point. This is illustrated below with
time-tags 2, 5, 7, and 14. When transitions do occur, two samples are stored for every
transition. Therefore, with 2 K samples of memory, 1 K of transitions are stored. You
must subtract one, which is necessary for a starting point, for a minimum of 1023 stored
transitions.

Maximum transitions stored
If transitions occur at a fast rate, such that there is a transition at each sample point,
only one sample is stored for each transition as shown by time tags 17 through 21 below.
If this continues for the entire trace, the number of transitions stored is 2 K samples.
Again, you must subtract the starting point sample, which then yields a maximum of
2047 stored transitions.

In most cases a transitional timing trace is stored by a mixture of the minimum and
maximum cases. Therefore, in this example the actual number of transitions stored will
be between 1023 and 2047.

Transitional timing considerations
Data storage
When an edge is detected, two samples are stored across all channels assigned to the
timing analyzer. The need of two samples is to avoid loss of data if a second edge were to
occur to soon after the first edge for the edge detectors to reset.
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Sequence level branching
In transitional timing, only 2 branches are available per sequence level.

Global counters
In transitional timing, only one global counter is available.

Storing Time Tags
Transitional timing requires time tags to recreate the data. Time tags are stored by
interleaving them with measurement data in memory.

Increasing Duration of Storage
The analyzer looks for transitions on all bits assigned to a bus.  Therefor, to increase
usable memory depth and acquisition time, remove bits with transitions on signals like
clock or strobe that add little useful information to the measurement when no other
signals transition.

Invalid Data
The analyzer only looks for transitions on data lines on buses that are turned on. Data
lines on buses that are turned off store data, but only when one of the lines that is turned
on transitions. If the data line on a bus is turned on after a run, or the data line is
assigned to a new bus, you would see data, but it is unlikely that every transition that
occurred

Trigger Position
In transitional timing, no data prestore (samples acquired before trigger) is required.
Therefore, much like state mode, the trigger position (start/center/end) will indicate the
percentage of memory filled with samples after the trigger. The number of samples
acquired/ displayed before trigger will vary between measurements.
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Triggering

Triggering
Triggering the logic analyzer at the correct time is important because it allows you to
store only the data you want to see and analyze.  The more accurate the trigger point,
the more precise the captured data set will be surrounding the malfunction in the target
system.

In many measurements the trigger point can be as simple as an occurrence of a data
pattern on a bus, or a rising edge on a clock line.  In more advanced measurements, the
trigger point would occur only after a series of bus patterns, edges, and qualifying time
periods.

Depending on the measurement, the logic analyzer can be triggered in the following
ways:

Simple trigger

Advanced trigger dialog

External trigger

See Also
Trigger Functions
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Simple Trigger Tasks

Simple Trigger

The Simple Trigger allows you to quickly create simple triggers like edges and bus
patterns within the waveform or listing window.  Bus data is compared to a relational
operator (example; equal to, not equal to) and a user-defined value.  Single signals are
compared to options such as a rising or falling edge, or a low or high level.  In the state
acquisition mode, edges are not available.  When a bus pattern and/or signal match the
user defined expression, the analyzer triggers.

When both a bus and signal are used in an expression, they are ANDed together with the
restriction that only one edge can be set.  In cases where multiple edges are set, the last
edge set has priority, while all others are changed to don't cares (X).

When a trigger condition requires more than a simple AND/OR expression, such as using
multiple sequence steps, or the use of timers and counters, you can choose to use the
advance trigger dialog.  When the advanced trigger dialog is used, and a trigger
expression is configured that surpassed the functional limits of the simple trigger, the
simple trigger fields go away.  To restore the operation of the simple trigger, you must
either change the existing advanced trigger configuration to use bus patterns and edges
within the scope of the simple trigger, or, click in the simple trigger field, then choose
Simple Trigger to reset the trigger.

Up to the point where the advanced trigger surpasses the functionality limits of the
simple trigger, both the simple trigger fields and the advanced trigger dialog will show the
current trigger configuration and are available for trigger modification.  However, as
mentioned above, as soon as changes in the advanced trigger dialog surpass the simple
trigger functional limits, the simple trigger fields go away.

In the case where a signal and bus overlap, that is, any signal that is actually part of the
group of signals making up the bus, the last change has highest priority. For example, a
bus pattern has been set to trigger the analyzer, you then set an overlapping signal
(channel 1 of same bus) to trigger on a rising edge.  By changing the signal, the bus
pattern trigger is now discarded.
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To set bus pattern triggers

To set signal trigger options

See Also
Set quick trigger with rectangle

To store a trigger

To recall a trigger

Advanced trigger dialog

Trigger Functions
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To set bus pattern triggers
Bus pattern triggers are part of the Simple Trigger and are used to quickly select a
qualifier to compare the incoming bus to.  Bus data is compared to an operator (example;
equal to, not equal to) and a user-defined value.  When a bus pattern matches the
defined bus pattern trigger, the analyzer triggers.  A complete list of operators is listed
below.

The Simple Trigger is located in both listing and waveform display windows.

1. In the Simple Trigger field, click on the pattern qualifier  field and set it to
the desired operator.

2. Click in the text entry field  and enter the desired data pattern.

Operators
� Equal To

� Not Equal To

� In Range

� Not In Range

� Greater Than

� Greater Than Or Equal To

� Less Than

� Less Than Or Equal To

See Also
To set signal trigger options

Advanced Trigger Dialog
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To set signal trigger options
Signal trigger options are part of the Simple Trigger and are used to quickly select a
qualifier to compare the incoming signal to.  Signals are compared to options such as a
rising edge or falling edge.  When the analyzer detects a match with the defined option,
the analyzer triggers.  A complete list of available options is shown below.

The Simple Trigger is located in both listing and waveform display windows.

1. In the Simple Trigger field, click on the signal option  field and set
it to the desired option.

Options
� Rising Edge

� Falling Edge

� Either Edge

� Glitch

� High

� Low

� Don't Care

Note:  In State acquisition mode, edge options are not available.

To triggering on a glitch
When Glitch is selected as the signal's trigger option,  the analyzer will trigger when a
glitch with a minimum width of 1.5 ns appears on the signal line.  Because the glitch is
not drawn on screen,  the use of an oscilloscope is required to further troubleshoot when
the glitch occurs.

See Also
To set bus pattern triggers

Advanced Trigger Dialog
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Advanced Trigger Tasks

Advanced Trigger Dialog

The Advanced Trigger dialog is used to configure the advanced triggers that require
multiple conditions to be true before a trigger occurs.  Each acquisition mode (state or
timing) has its own set of trigger functions.  Trigger functions are represented by blue
boxes, and are drag-and-dropped onto the trigger sequence display area in the order in
which you want them executed.

The Advanced Trigger dialog is accessed through the menu bar Setup>Advanced
Trigger... .  The following tasks are performed in the dialog:

To build a trigger sequence

� To set store qualification - (State mode only)

� To insert events and actions

� To negate a function statement

� To modify trigger step display

� ANDing and ORing event statements

To store a trigger

To recall a trigger

See Also
State mode trigger functions

Timing mode trigger functions

Simple Trigger
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To build a trigger sequence
The trigger functions included in the advanced trigger dialog give you pre-configured
trigger sequences that will work for most measurements.  In the case where you have to
build a custom trigger sequence for your particular measurements, the following overview
shows you how to build a trigger sequence.

1. From the menu bar, click Setup>Advanced Trigger... .

2. From the Advanced Trigger dialog, drag and drop the desired Trigger Function
into the Trigger Sequence display area.

Replace - To replace an existing function, drag and drop the new function on top of the
old one.  A red box around the old function indicates the replace operation.

Add above/below - To add multiple functions, drag and drop the new functions above
or below the existing function.  When the mouse is positioned above or below an
existing function, a red insert bar appears to indicate relative insert location of the new
function.

Trigger steps
Each trigger function added to the trigger sequence displays a trigger Step.  Trigger
steps illustrate in sentence form how the function evaluates data to find the trigger point.
The evaluation process continues within the trigger step until either the trigger is found,
or an instruction is encountered that sends evaluation to another trigger step.  Each
trigger function added to the sequence adds another trigger step.

For custom trigger sequences, each trigger step can be modified in the following ways:

To set store qualification - (State mode only)

To insert events and actions

To negate a function statement

To modify trigger step display

See Also
To store a trigger

To recall a trigger

State mode trigger functions

Timing mode trigger functions
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To set store qualification
Storage qualification is used to determine if an acquired sample should be stored (that is,
placed in memory) or thrown away. This keeps the logic analyzer memory from being
filled with samples that are not needed.

Default storage
The simplest method to set up storage qualification is by setting up the Default Storage.
This is specified separate from the trigger sequence as shown below.

Default storage means "unless sequence step storage specifies otherwise, this is what
should be stored".  Sequence step storage always overrides default storage.

Example:  Before the analyzer triggers, you only want to store samples if ADDR is
greater than E5.  Set the Default Storage as follows:

By default, the default storage is set to store all samples acquired. You can also set the
default storage to store nothing, which means that no samples will be stored unless the
sequence step storage overrides the default storage.

Sequence step storage
Sequence step storage means that within a particular sequence step only certain samples
are stored. This also means that until a "Go To" or "Trigger" action is used to leave the
sequence step, the sequence step storage applies. This is useful when you want different
sequence step storage qualification for each sequence step.

Example:  You want default storage to store nothing before trigger, then you want
sequence step storage to store samples when ADDR is greater than E5, starting when E5
has occurred for the 3rd time.
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Storage interaction
Remember, sequence step storage always overrides default storage, but only for the
conditions specifically configured in the sequence step storage. You must be very careful
that you account for the interaction between default storage and sequence step storage.

For example, if you want to store only samples with ADDR in the range 5000 to 6FFF
while looking for DATA = 005E, the following sequence level could be used in some
situations:

Notice the use of the Store sample action. This means "store the most recently acquired
sample in memory now". It does not mean, "From now on, start storing". Since the store
sample action is never executed unless ADDR is in the range 5000 to 6FFF, this branch
essentially means "While in this sequence step, store only samples with ADDR between
5000 and 6FFF".

The above example seems to imply that only samples with ADDR between 5000 and 6FFF
will be stored. However, this depends upon how the default storage has been set up.
Using the previous example, if the default storage is set to "Store Everything", and a
sample is outside of the range 5000 to 6FFF, then the Else If branch is not executed and
the Default Storage is applied. In essence, the sequence step has said what to do when a
sample has a value in a particular range, but it doesn't say what to do for samples
outside the range. Therefore, if you want to specify the sequence step storage
unambiguously, use the following:
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Alternatively, if the default storage is set to "Store Anything", use the following:
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How to read event and action
statements

Your measurement goal is to see what data is stored in memory at the address value
406F6.  To do this, you configure the trigger function to look for the pattern 406F6
(hexadecimal) on the address bus, and a rising edge on the RD (memory read) clock line.

 As you configure the trigger function, try to think of it as constructing a sentence that
reads left-to-right.

For example:

 "Find a Bus named address, and on All bits, a pattern that Equals 406F6 Hex, And a
Signal named RD with a Rising Edge.  When found, then Trigger and fill memory".
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To insert events and actions

Events and Actions are statements, in sentence format, inserted into the trigger step to
expand its functionality.

Events are used to qualify what data is being evaluated, and what data or process is
being acted upon.  When multiple event statements are used, you have the choice to
combine them with either the AND or OR logic operators.  The following Event options are
available:

� Bus/Signal

� Anything

� Nothing

� Timer

� Counter

� Arm in from Ext. trigger

Actions are used to start processes such as timers or counters, or to start filling
memory.  When multiple action statements are used, they are combined using the AND
logic operators.  The following Action options are available:

� Timer

� Counter

� Store sample

� Don't store sample

1. Within the trigger step, click the  Event and  Action buttons, then select
insert statements Before and After as desired.  If a choice is inappropriate, it is
greyed out.

2. Configure the new Action or Event fields that appear.  The figure below illustrates
the type of selections available.  Make choices according to the specific needs of
your measurement.  See "Example of how to read event and action statements".
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See Also
To set store qualification

ANDing and ORing Event statements

To configure a timer

To configure a counter

To store a trigger

To recall a trigger
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To negate a function statement

When you negate a statement in a trigger function, you are asking the analyzer to
evaluate the statement as an opposite.
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To modify trigger step display

All trigger functions by default are displayed in a short form that allows you to modify
them when necessary. However, the trigger step can also be displayed in two optional
ways that enable you to see them without the graphical buttons and fields, or in an
expanded form with graphical buttons and fields.

Note: The Advanced (If/Then, or Branch) trigger functions do not allow alternative
display types.  By default, they are in the expanded graphical form that cannot be
changed.  See the If/then (can't undo) choice below.

1. In the Trigger Sequence display area, click the  button in the trigger
step.

2. Select the desired display choice.

� Default - In most cases, the default form of the trigger function has all the
necessary elements for a trigger.  It appears in a short form which can hide
such elements as internal occurrence counter and timer functions.

� If/then (read-only) - This choice converts the trigger step into read only
text.  This choice can be switched back to the default form of configurable
fields.

� If/then (can't undo) - This choice converts the trigger step into an
Advanced IF/Then form similar to the IF/Then trigger functions under the
Advanced tab.  This choice cannot be switched back to the default form.
However, since this choice is just an expanded form of the default with
configurable fields, editing the trigger step in this form is viable.

An advantage of this form is that you have access to elements such as internal
occurrence counter and timer functions.  The disadvantage is that you cannot
convert back to the short form of the trigger function.

The following figure shows the same Edge trigger function in all three forms.

Step 1 = Default

Step 2 = If/then (read only)

Step 3 = If/then (can't undo)
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ANDing and ORing Event statements
When you add multiple event statements to form a complex trigger step, the statements
are combined using the logical operators AND and OR.  Parentheses are also
automatically added to help show how the statement is partitioned during evaluation.

See Also
To insert event statements



180

To store a trigger
Depending on how you want to recall stored triggers, the logic analyzer enables you to
store your trigger specification in two ways.

Most recently used trigger list
Each time you setup a new trigger and run the measurement, the trigger setup is stored
automatically in a "Most recently used trigger" list in the analyzer.

Note: The analyzer must be run before the trigger setup is stored.  Also, trigger setups
are stored as part of the configuration file.  If you load a new configuration file, the trigger
setups will be overwritten by trigger setups stored with the new file.

To view triggers stored automatically, click Setup>Recall Trigger, then look in the
"Most recently used trigger" list.  If the list gets to long, you can move them to the
"Stored favorite triggers" list.  The number of items allowed in the list is set by
Edit>Options>Trigger History Depth.

Stored favorite triggers list
When you force a save trigger operation before the measurement is run, the trigger is
placed in the "Stored favorite triggers" list.    The number of items allowed in the list is
set by Edit>Options>Recent File List Size.

1. From the menu bar, click Setup>Advanced Trigger.

2. From the Advanced Trigger dialog, configure the trigger specification, then click
Store.

3. Click Ok.

Optional:  You can also store a trigger through the menu bar.  Click
Setup>Store Trigger.

See Also
To recall a trigger
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Recall Trigger Dialog
After a trigger is stored, it is placed in a recall list for use at a later time.  Use the Recall
Trigger dialog to recall a previously used trigger, save a trigger in a favorites list, view
trigger details, or rename the trigger to a custom name.

Note: Saved triggers are part of a the current configuration.  If you load a new
configuration file, saved triggers in the current recall list are lost.

 

Rename Allow you to edit the name of the highlighted trigger.

Clear Clears the highlighted trigger from the list.

Clear All Clears all triggers from recall lists.

Details Shows complete definition of the highlighted trigger.

To recall a trigger
1. From the menu bar click Setup>Recall Trigger...

2. Select the desired trigger, then click Ok.

See Also
To store a trigger



182

To configure a counter
Counters are available in both Event and Action statements, and like other events, they
evaluate to either true or false.  Use counters to create a user-defined delay, or to create
a standard against which valid data duration is evaluated.  Once configured, a counter
persists throughout all the steps of the trigger sequence.

Counter considerations:

� Maximum counters available is 2.

� When using counters in the transitional timing mode, one counter is used
internally so only one counter is available in a sequence step.

� Once a counter is configured, you can reuse the counter by selecting its
identification number.  Each use of the counter must check it for the same value.

Note:  The logic analyzer also has occurrence counters, and a reset occurrence
counter action.  Occurrence counters only exist within steps that contain the "occurs"
phrase and are not affected by the other counter actions described on this page.

To insert a counter event
A counter must be started with a counter action before it can be evaluated with a counter
event.

1. From within the trigger Step, select the event type button, and from the
selection list that appears, select Counter.

2. Select the counter number button and choose the number of the counter you
want to test.

3. Select the operator button and choose either >= or <.

4. Enter the count value.

To insert a counter action
1. From within the trigger Step, select the insert action button, then select Insert

Action Before.

2. Select the action type button, and from the selection list that appears, select
Counter.



183

3. Select the counter number button and choose the number of the counter you
want to test.

4. Select the operator button and choose either Increment, or Reset.

See Also
To configure a timer

To build a trigger sequence

To modify trigger step display

To negate a function statement
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To configure a timer
Timers are like stopwatches.  Use timers to create either a user-defined delay or a time
standard which valid data duration is evaluated against.  The timer can Start from reset,
Stop and reset, Pause, or Resume.

Timer considerations:

� Depending on the analyzer model and acquisition mode, available timers are as
follows:

Model Timing Acquisition
Mode

State Acquisition Mode

1680/90 3 timers available 4 timers available

1681/91 2 timers available 3 timers available

1682/92 1 timer available 2 timers available

1683/93 0 timers available 1 timer available

� Timers are checked in event statements, and started in action statements.

� Timers must be started before they can be checked.  This is done by either
including the timer start action with the timer check event within the same trigger
step or starting the timer in a preceding trigger step. The following example
shows the timer start action and check event within the same trigger
step.

� Once a timer event is configured, you can reuse the timer by selecting its
identification number.  The same timer must always be checked against the same
value.  To check for different durations, use different timers.

To insert a timer check event
1. From within the trigger step, select the insert event button, then select Insert

Event Before.

2. Select the event type button, and from the selection list that appears, select
Timer.



185

3. Select the timer identification button and choose the number of the timer you
want to use.

4. Select the operator button and choose either >= or <.

5. Enter the time value.

To insert a timer start action
1. From within the trigger step, select the insert action button, then select Insert

Action Before.

2. Select the action type button, and from the selection list that appears, select
Timer.

3. Select the timer number button and choose the number of the timer you want
to check.

4. Select the operator button and choose either Start from reset, Stop and reset,
Pause, or Resume.
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Note: As stated above in timer considerations, the timer start action can be placed in
either the same trigger step as the timer check event, or it can be placed in a preceding
trigger step.  Checking a timer without starting it will generate an error.

See Also
To configure a counter

To build a trigger sequence

To modify trigger step display

To negate a function statement
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Marker Tasks

To create new markers
When you create a new marker, you have the option of customizing it with a user-defined
name and color.  You can also position it precisely in data by either a time value or
sample number, or by a data value.  Up to 1024 markers can be created.

1. From the menu bar, select Markers>New.

2. From the New Marker dialog, either accept the new default marker name and
color, or assign a custom name and color.

3. Configure the position of the new marker in the data by one of the following
methods:

� Time - Position the marker by a time value from a reference point.  Reference
points are the Trigger, Beginning of Data, End of Data, or another Marker.

� Sample - Position the marker by a number of samples from a reference point.
Reference points are the Trigger, Beginning of Data, End of Data, or another
Marker.

� Value - Position the marker at a user defined value.  Click the Occurs field
and configure the find data options.

Using abbreviated names
Marker names can be very descriptive. The problem with descriptive marker names is
that they are long and take up room on the display. To keep a descriptive marker name
and also minimize the amount of display real estate used, an abbreviated name can be
defined.  The abbreviated name is defined by including “[]” within the descriptive name.

Example:

The name for the trigger marker is defined as: Trigger[T]. The word “Trigger” is the
descriptive name that appears within the marker tool tip. The “[T]”is the abbreviated
name that appears within the marker display bar. If an abbreviated name is not defined
within a descriptive name, the descriptive name will be displayed within the marker
display bar.

See Also
To place markers in data

Go To markers

Reading off-screen markers

To center the display about a marker

To delete a marker

To rename a marker

To sent a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge
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To place markers in data
Use Place Markers to quickly position a pre-defined marker in the data. Depending on
how you access the Place Markers feature, the marker is placed in the data a little
differently.

You can also move markers by dragging with the mouse or using the front-panel knobs.

Place marker at center screen
1. From the menu bar click Markers>Place On Screen.

2. Select the desired marker, then select OK.  The marker will be placed at mid-
screen.

Place marker at mouse cursor
1. Point the mouse to the desired data point in the display.

2. Right-click the mouse, and select Place Markers.

3. Select the desired marker, then select OK.  The marker is placed in the data at
the point where the mouse cursor was pointing.

See Also
To create new markers

Go To markers

Reading off-screen markers

To center the display about a marker

To delete a marker

To rename a marker

To send a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge
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Go To Markers
Use the Go To markers feature to quickly find a previously set marker in the data, or the
beginning of data, end of data, or the trigger point.  The selected marker appears at the
center of the display.

1. From the menu bar, select Markers>Go To... or select the  icon in the
markers toolbar.

2. Select the marker you wish to find from the list provided.

3. Click OK.

See Also
To create new markers

To place markers in data

To center the display about a marker

To delete a marker

To rename a marker

To sent a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge
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To center the display about a marker
Use the center about feature to center the display around a selected marker pair.  If the
marker pair is separated by a large time or sample amount, the scale of the display is
automatically changed so both markers appear on screen.

Since the center about feature centers the display around a pair (two) markers, if you
have three or more markers defined, you will have available choices for all possible
combinations of two.

1. From the menu bar, select Markers>Center About.

2. Select the desired marker combination, then select OK.  The center of data
between the selected markers is set at mid-screen.

See Also
To create new markers

To place markers in data

Go To markers

To delete a marker

To rename a marker

To sent a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge
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To delete a marker
1. In the Marker Display Bar, point the mouse cursor over the marker you want to

delete.

2. Right-click the mouse, then select Delete.  The marker under the mouse cursor is
deleted.  To delete all markers, select Delete All.

See Also
To create new markers

To place markers in data

Go To markers

To center the display about a marker

To rename a marker

To sent a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge
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To rename a marker
The rename marker feature allows you to change the marker name.

1. Click in the Marker box, then select the marker you wish to rename.

2. Select Rename..., then from the pop-up keypad that appears, type in the new
name.

3. Select Ok.

See Also
To create new markers

To place markers in data

Go To markers

To center the display about a marker

To delete a marker

To send a marker to the back

To set marker properties

To drag and drop markers in data

Marker snap to edge
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To send a marker to the back
This feature is used to toggle between markers that are located in the same position. This
feature can be accessed by right clicking on the marker you want move.

1. Right click on the marker you wish to send to the back.

2. Select Send to Back from the pop-up menu.

See Also
To create new markers

To place markers in data

Go To markers

To center the display about a marker

To delete a marker

To rename a marker

To set marker properties

To drag and drop markers in data

Marker snap to edge
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To set marker properties
Once a marker is created, you can modify any of its attributes from the Marker Properties
tab.  To access marker properties, click Markers>Properties from the menu bar, then
click the Markers Properties tab.

Tip:  You can also access the Properties dialog by a right-click in the display area,
then select Properties.

To rename the marker

To change the marker color

To lock marker in viewer

To change the marker type

Marker snap to edge

To rename the marker
1. From the Marker properties tab, select the Marker to rename.

2. Select the Rename button, and from the Rename keypad that appears, type the
new name, then select Ok.

Using abbreviated names
Marker names can be very descriptive. The problem with descriptive marker names is
that they are long and take up room on the display. To keep a descriptive marker name
and also minimize the amount of display real estate used, an abbreviated name can be
defined.  The abbreviated name is defined by including “[]” within the descriptive name.

Example:

The name for the trigger marker is defined as: Trigger[T]. The word “Trigger” is the
descriptive name that appears within the marker tool tip. The “[T]”is the abbreviated
name that appears within the marker display bar. If an abbreviated name is not defined
within a descriptive name, the descriptive name will be displayed within the marker
display bar.

To change the marker color
1. From the Marker properties tab, select the Marker you want to change.

2. Select the marker Color button, and from the color palette that appears, select
the new color.  For custom colors, select the Other... button and create the
desired color from the color dialog that appears.

To hide the marker
1. From the Marker properties tab, select the Marker you want to hide.

2. Check the Hide box. When a marker is hidden, all assigned marker properties are
retained, it is just hidden from view in the display.

To lock marker in viewer
When viewing data in multiple display viewers, you can make a marker in one display
move and remain viewable in another display.  In other words, when a marker is locked
in the viewer, it will follow the movement of the same maker as it is moved in another
viewer.

This applies only when a marker is dragged within the immediate data viewing area. If a
marker is moved by defining a new location using the markers properties dialog, it is not
guaranteed to stay in view within any of the viewers.

1. From the Marker properties tab, select the Marker you want to lock in the
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display.

2. Check the Lock in Viewer box, then click Ok.

To change the marker type
1. From the Marker properties tab, select the Marker you want to change.

2. In the "Position" area of the properties dialog, select the marker type name
(Example; Time) and from the selection list that appears, select the new type.
When the marker type is changed between Time and Sample, the marker position
in the data does not change, just the unit of measure.

 See Also
To create new markers

To place markers in data

Go To markers

To center the display about a marker

To delete a marker

To rename a marker

To sent a marker to the back

To drag and drop markers in data

Reading off-screen markers
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To drag and drop markers in data
Using the drag and drop feature you can move markers to new positions in the data.

1. Click and hold down the mouse button on the marker you wish to move.

2. Move the mouse cursor to the new position.

3. Release the mouse button to reposition the marker.

See Also
To create new markers

To place markers in data

Go To markers

To center the display about a marker

To delete a marker

To rename a marker

To sent a marker to the back

To set marker properties

Marker snap to edge
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Reading off-screen markers

In the upper marker display bar, markers are color coded and displayed with arrows that
point to the marker's relative location to the locally (current window) displayed data.  In
the lower marker display bar, markers are displayed as color coded bars showing relative
location within the data record (global).

In the waveform display as shown above, the marker display bars appear on the
top/bottom of the display window.  In the listing display, the marker display bars appear
on the left/right sides of the display window in a similar way.

Tip:  You can quickly display a different region of data from the data set by double-
clicking on the global marker display bar at the bottom (waveform) or right side
(listing).
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File Management Tasks

File management
To open a configuration file

To save a configuration file

To recall a recently used configuration file

To export files

To import files

See Also
The XML Format

The CSV Format

The ALA Format
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To open a configuration file

1. From the menu bar, select File>Open or select the  icon in the standard
toolbar.

2. Select the file configuration you wish to open.

3. Select Open.

Note: Configuration files that include trace data will be much larger than files that do
not contain trace data.

The Owner, Project, and Description dialogs are used to help identify configuration
files. The configuration file was created with the software version shown in the Version
dialog.  The Date dialog displays the date the configuration file was created. The Setup
only checkbox is checked if the configuration file contains only the instrument settings.
If the Setup only box is not checked then the configuration files contains the instrument
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settings and the trace data.

Note: If you are using the logic analyzer without a keyboard, you can access an on-
screen keyboard by selecting Start>Programs>Accessories>Accessibility>On-
Screen Keyboard.

See Also
The ALA Format

To import files

To export files
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To save a configuration file
The save feature allows you to save a configuration file for later use. The first time a file
is saved the logic analyzer configuration file dialog box will appear.  The Save As...
feature allows an existing configuration file to be saved under a different name.

1. From the menu bar, select File>Save or select the  icon in the standard
toolbar.

2. Enter the name of the configuration you wish to save.

3. If desired, complete the Owner, Project, and Description dialogs. These
dialogs help to identify the configuration files when they are reopened.

4. Select the Setup only checkbox if you wish to save only the instrument settings
and not the trace data.

Note: Configuration files that include trace data will be much larger than files that do
not contain trace data.

5. Select Save.

The Version and Date dialogs are automatically generated and cannot be edited. The
configuration file was created with the software version shown in the Version dialog. The
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Date dialog displays the date in which the configuration file was created.

Note: If you are using the logic analyzer without a keyboard, you can access an on-
screen keyboard by selecting Start>Programs>Accessories>Accessibility>On-
Screen Keyboard.

See Also
The ALA Format

To import files

To export files
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To recall a recently used configuration
file

1. From the menu bar, select File.

2. Select the configuration file you wish to open from the list provided.
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To import files
The Import dialog allows you to import XML based text files previously exported using the
Export dialog or created using the Config Translator Application.  The imported file may
contain data or just the configuration setup information.

Import/Export considerations:

� Neither XML or CSV files can re-create a complete logic analyzer configuration.
Use configuration files (.ala) if you want to reload complete data and tool
configurations.

� CSV files cannot be imported back into the logic analyzer.

� XML files can be imported, but some tool configuration information is lost.  See
below for a complete list.

� Generally, exported files should be imported into similar analyzers (same
hardware configuration).

� Bus/signal folders are not imported.  All bus/signals names are imported back to
the root level of the bus/signal name.

� Clock channel mapping is not imported.

Note:  If it is important to keep clock channel mapping, use configuration files
(.ala) .

To import a file
1. From the menu bar, select File>Import.

2. In the File name: field, type in the desired file name.

3. In the Files of type: field, select the .txt file format type.

4. Click Open.

 
While running an import, all other operations are disabled until either the user cancels the
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import via the cancel  toolbar button, or the import operation completes.  The status
bar at the bottom of the display will show the progress of the import process.

Information not imported from XML file
� Clock channel mapping.

� In state acquisition mode, the clock mode and clock description.

� Bus and signal order.  (Names and channel assignments are exported.)

� Filter information.  (Other tool types are exported.)

� Interface layout.

� Changes in column or row properties.

� Marker information.

� Trigger history.

Note: If any of the above items are important to your post-processing, please save
data in a configuration (*.ala) file.

See Also
The XML Format

To export files

Config Translator Application
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To export files
The Export dialog allows you to export most configuration setup information,
measurement data, and generated tool data such as Inverse Assemblers to a file on a
disk.  Data is exported in either in XML text format (.txt) or Comma Separated Value
format (.csv).

Import/Export considerations:

� Neither XML or CSV files can re-create a complete logic analyzer configuration.
Use configuration files (.ala) if you want to reload complete data and tool
configurations.

� CSV files cannot be imported back into the logic analyzer.

� XML files can be imported, but some tool configuration information is lost.  See
below for a complete list.

� Generally, exported files should be imported into similar analyzers (same
hardware configuration).

� Bus/signal folders are not imported.  All bus/signals names are imported back to
the root level of the bus/signal name.

� Clock channel mapping is not imported.

Note:  If it is important to keep clock channel mapping, use configuration files
(.ala) .

To export a file
1. From the menu bar, select File>Export.

2. In the File name: field, type in the desired file name.

3. In the Save as type: field, select the desired file format type.

4. In the Data Range section, select the data range you want to export.

� All - Exports all data in memory.

� Time - Exports data between the specified time values.

� Sample - Exports data between the specified sample numbers.

� Marker - Exports data between the specified markers.

� Setup Only - Exports only measurement configuration, no data.

5. Click
Save.
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Note:  When selecting a range of samples, be sure to include the ending transition to
ensure a complete display of the selected range.  The last sample specified is not included
in the output.

While running an export, all other analyzer operations are disabled until either you cancel

the export operation using the cancel button  in the toolbar, or the export operation
completes.  The status bar at the bottom of the display window shows the progress of the
export process.

Information not imported from XML file
� Clock channel mapping.

� In state acquisition mode, the clock mode and clock description.

� Bus and signal order.  (Names and channel assignments are exported.)

� Filter information.  (Other tool types are exported.)

� Interface layout.

� Changes in column or row properties.

� Marker information.
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� Trigger history.

See Also
The XML Format

The CSV Format

To import data
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Searching

Searching
The logic analyzer allows you to search for data patterns, time values, or sample
numbers.

To search for a value - This search option locates a specified data pattern or value.  You
can qualify your search by specific bits, data patterns, equality, and range operators. The
search result is placed at the center of the display.

To perform complex pattern searches - This search option locates specified data patterns
or values by expanding the search criteria to include more than one event. You can
qualify your search by specific bits, data patterns, equality, and range operators. The
search result is placed at the center of the display.

To Go To a specific position in the acquisition - This search option locates an individual
time value, sample number, or a marker. The search result is placed at the center of the
display.
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To search for a value
This search option locates a specified data pattern.  You can qualify your search by
specific bits, data patterns, equality, and range operators. The search result is placed at
the center of the display.

1. From the menu bar select, Edit>Find or click the  icon in the standard
toolbar.

2. In the Find dialog, select the number of the occurrences you wish to find, then
choose the start location.

Note: Positive numbers indicate that the search operation should proceed towards
the end of the data. Negative numbers indicate that the search operation should
proceed towards the beginning of the data.

3. Configure the event you wish to locate.

4. Click OK.

5. Click the Previous  or Next  icons to see more occurrences.

Tip: As you configure the find function, try to think of it as constructing a sentence
that reads left-to-right.
 For example:

 "Find 1 occurrence from the Display Center of a bus named My Bus 1, and on All bits a
pattern that Equals XX Hex, display the event When all criteria is Present."

Note: The find qualifiers with an operator (Present>, Present>=, Present<=, Present>)
and the "Present for Range" and "Not Present for Range" allow the user to specify a time
duration. This means that the find event specified in the expression area will be found
based upon the given time and operator. The other qualifiers (Present, Not Present, and
Entering) do not allow a time duration.

See Also
To perform complex pattern searches

Store Favorite

Recall Favorite

Options
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To perform complex pattern searches
This search option locates specified data patterns by expanding the search criteria to
include more than one event. You can qualify your search by specific bits, data patterns,
equality, and range operators. The search result is placed at the center of the display.

1. From the menu bar select, Edit>Find or click the  icon in the standard
toolbar.

2. In the Find dialog, select the number of the occurrences you wish to find, then
choose the start location.

Note: Positive numbers indicate that the search operation should proceed towards
the end of the data. Negative numbers indicate that the search operation should
proceed towards the beginning of the data.

3. Configure the event you wish to locate.

4. Select the drop down menu to choose the type of event you wish to add.  Select
Insert Event After to insert a new find event after the current event, or select
Insert Event Before to insert a new find event before the current event. The
Delete Event option will delete the current event only if there is more than one
event present.

5. Select either AND or OR from the box that appears after you add a search
option. AND'ed searches find occurrences of both events, while OR'ed searches
find occurrences of either event.

6. Select the bus or signal name and enter the value you want to locate.

7. Click OK.

8. Click the Previous  or Next  icons to see more occurrences.

Tip: As you configure the find function, try to think of it as constructing a sentence
that reads left-to-right.
 For example:

 "Find 1 occurrence from the Display Center of a bus named My Bus 1, and on All bits a
pattern that Equals XX Hex, display the event When all criteria is Present."
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Note: The find qualifiers with an operator (Present>, Present>=, Present<=, Present>)
and the "Present for Range" and "Not Present for Range" allow the user to specify a time
duration. This means that the find event specified in the expression area will be found
based upon the given time and operator. The other qualifiers (Present, Not Present, and
Entering) do not allow a time duration.

See Also
To search for a value

Store Favorite

Recall Favorite

Options
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To Go To a specific position in the
acquisition

This search option locates a specified time value, sample number, or a marker. The
search result is placed at the center of the display.

1. From the menu bar, select Edit>Go To.

2. From the Go To dialog, choose either Time, Sample, or Markers.

3. Enter the value you want to locate or select the marker you want to locate.

4. Click OK.

Tip:  You can also access the Go To dialog by right-clicking in the display area.
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Favorite Find Pattern
To store a favorite a pattern

To recall a favorite pattern

To delete a favorite pattern

To store a favorite pattern

1. From the menu bar select, Edit>Find, or click the  icon.

2. Set up the pattern you want to find.

3. Click Save Favorite.

4. Enter the name of the pattern.

5. Click OK to save the pattern.

To recall a favorite pattern

1. From the menu bar select, Edit>Find, or click the  icon.

2. Select Recall Favorite, then select the pattern you want to use from the drop
down menu.
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3. Click OK.

To delete a favorite pattern

1. From the menu bar select, Edit>Find, or click the  icon.

2. Select Recall Favorite, then select Clear.

Note: To clear all of the patterns, select Clear All.

3. Select the pattern you wish to delete from the list provided.

4. Select Clear.

See Also
Searching

Find Options
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Find Options
When searching for a pattern you can place a marker at the occurrence.

1. From the menu bar select, Edit>Find, or click the  icon in the standard
toolbar.

2. Setup the pattern you want to find.

3. Click Options.

To use the Place function
1. Select Place, then choose the marker you want to place from the drop down

menu.

a. For <new marker>, enter the name of the new marker.

b. Select Create new marker... if you want a new marker at each occurrence of
the pattern.

2. Select OK.

To use the Place new marker on each occurrence
function

1. Select Place new marker on each occurrence.

2. Enter the name of the new marker.

3. Select OK.

See Also
Searching

Favorite Find Pattern
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Capturing Data

Capturing Data

A logic analyzer is used to view timing relationships among many signals, or if you need
to trigger on patterns of logic highs and lows. A logic analyzer is actually two analyzers in
one: a timing analyzer and a state analyzer. A  timing analyzer is a logic analyzer that
samples based on an internal clock signal. This kind of sampling is also known as
asynchronous sampling.  A state analyzer is a logic analyzer that samples based on a
clock signal (or signals) from the device under test.  Typically, the signal used to set up
sampling is a state machine or microprocessor clock signal.  This type of sampling is also
known as synchronous sampling.

How to set up logic analyzer measurements.

� To set the acquisition mode -  Before viewing a signal, you must select either a
timing analyzer or a state analyzer.  A timing analyzer samples based on an
internal clock, and a state analyzer samples based on a clock signal from the
device under test.

� To set the sampling period - The timing analyzer works by sampling the input
waveforms to determine whether they are high or low. The state analyzer has to
restrict the sampling of data to times when only the desired data is valid and
appears on the signal lines.

� To start/stop measurements - There are two types of run modes; the single run
measurement will save captured data to trace memory one time.  The run
repetitive measurement will save the captured data to trace memory repetitively.
Stopping a run determines how much data is captured and placed in trace
memory.

� Trigger position - The trigger position specifies the amount of trace memory used
for samples captured before the trigger.

� Triggering

� Simple Trigger - The Simple Trigger allows you to quickly select a qualifier to
compare the incoming bus or signal with.

� Advanced Trigger - The Advanced Trigger is used to configure triggers that
require multiple conditions to be true before a trigger occurs.
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To start/stop measurements

To run the analyzer in single mode - The single run measurement will save captured data
to trace memory one time.  The amount of data stored during a single run is equal to the
amount of trace memory allotted.  For example, if trace memory is equal to 2M then the
amount of data stored after one run is equal to 2M.

To run the analyzer in repetitive run mode - The run repetitive measurement will save the
captured data to trace memory repetitively.  The amount of data stored in a repetitive
run is the same as a single run.  During a repetitive run once the trace memory is full the
system clears the trace memory and begins to refill with new data.  This cycle will
continue until the run is stopped.

To stop the analyzer - When a measurement is stopped the amount of data gathered is
equal to the amount of trace memory used up until the stop occurred.  For example, if
trace memory is equal to 2M and the measurement is stopped exactly half way through
the run then the amount of data in trace memory would equal 1M.

To run the analyzer in single mode

1. From the menu bar select Run/Stop>Run, or click the  icon from the
run/stop toolbar.

To run the analyzer in repetitive run mode

1. From the menu bar select Run/Stop>Run Repetitive, or click the  icon
from the run/stop toolbar.

To stop the analyzer

1. From the menu bar select Run/Stop>Stop, or click the  icon from the
run/stop toolbar.
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To print data and screens

To print data and screens
There are three ways to create printed documentation of your measurement.

� Print data

From the logic analyzer's File>Print dialog, print the current measurement data in
memory from either the listing or waveform display viewer windows.  You can print All
data, or print just a defined range of Time (waveform) or Samples (listing).  Data is
printed from smallest time/sample to largest.

� Copy text to clip board

When in the listing display window, you can draw a rectangle in the listing display area,
then copy the region.  Text is copied to the system clip board.  To print the text, you
must paste the text into a word processor or excel spreadsheet and print from that
application.

� Copy screen to clip board

Use the Edit>Copy Screen function to copy a bitmap of the active screen into the
system clip board. To print the screen, you must paste the bitmap into a graphics
editing program and print from that application.

Note:  The first time you access the print dialog, you are asked to install a printer.
Follow the directions in the printer install dialogs that appear.

To print data
1. From the menu bar, select File>Print... .

2. In the "Print What" section, select the desired display viewer window.

3. Click Options..., then select the desired bus/signals to print. To select a bus or
signal, click on the name in the left pane, then click the right-arrow button to
move the selection to the right pane. Click Ok.

4. In the "Print range" section, set the desired range using the "from" and "to" values.

5. Click OK to print the specified data.

To copy and print text
1. From the listing display area, position the mouse cursor over the upper-left

corner of the desired display region.

2. Click and hold the left mouse button, then drag the mouse cursor to the lower-
right corner.  Release the mouse button.  A rectangle is drawn around the defined
region (snaps to state lines and bus/signal columns).

3. From the shortcut list that appears, click Copy Text.

4. Open a word processor or excel spreadsheet program, paste the text into the
program, then print the screen.

To copy and print a screen
1. Click Edit>Copy Screen.  The currently displayed window is copied into the

windows clip board buffer.

2. Paste the contents of the clip board buffer into a graphics editing program of your
choice.

3. Print the screen from the graphics program.

See Also
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To Install a printer

To connect a LAN
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To install a printer
Local and network printers are installed outside of the logic analyzer environment using
the Windows printer install wizard.

1. Click Start>Settings>Printers.

2. Click on an existing printer, or click Add Printer.

3. Follow the Windows printer install wizard instructions.



222

To connect a LAN
Local area networks (LAN) are install outside of the logic analyzer environment using the
Windows network configuration wizard.

1. Click Start>Settings>Network and Dial-up Connections.

2. Click on an existing connection, or click Make New Connection.

3. Follow the Windows network install wizard instructions.
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Product Overview

Product Overview
The Agilent Technologies 1680/90-series logic analyzers provide a variety of channel
widths, memory depths, and state and timing acquisition speeds (see tables below).  The
1680A/AD-series comes with a large integrated 12.1-inch color flat panel display which
can show up to 22 waveforms on screen simultaneously.  The 1690A/AD-series is a PC-
hosted model which allows you to carry out your measurement and debug work in your
PC environment.

Both model series have the familiar Windows-based user interface which takes the
complexity out of making logic analyzer measurements.  You can perform all operations
directly from one window.  See "Intrinsic Support" below.

Agilent’s Simple, Quick and Advanced Trigger functions take the complexity out of
triggering. Use Simple Trigger’s pull down menus to define events in terms of edges and
patterns.   With Quick Trigger you can see if a suspect event ever reoccurs by just
drawing a box around the event in the display.  Quick trigger will do the rest!  Use
Advanced Trigger’s drag and drop graphical icons with sentence-like structures to
customize complex trigger scenarios.

Table of 1680A/AD-series channel, memory, and speed

Table of 1690A/AD-series channel, memory, and speed

Front Panel Operation

Characteristics

Specifications

Keyboard Commands

Supplied Accessories
1680A/AD-series 1690A/AD-series

PS2 mouse IEEE 1394 PCI card and cable

Mini keyboard Laptop IEEE 1394 cable

Front panel cover Accessory pouch

Accessory pouch

Optional Accessories
� Rack Mount Kit - Option 1CM

� Additional IEEE 1394 PCI card and cable

Documentation
Quick Start/Installation Guide

The Quick Start/Installation Guide gives you information on how to connect system peripherals
and probing.  Also included is an overview of the interface and information on installing
software upgrades.  Use this guide to quickly get familiar with the analyzer and also as a
future reference for keeping your analyzer up-to-date and running properly.

Online Help System
The Online Help gives you product reference and feature information.  Also included is a
tutorial showing you how to make a basic measurement and links to time-saving features and
concepts.
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Agilent Technologies Web Sites
Corporation/Contact

Corporation - http://www.agilent.com

Contact Us - http://www.agilent.com/find/contactus/

Notify Me - http://www.agilent.com/find/notifyme

Product Information
Logic Analysis - http://www.agilent.com/find/logicanalyzer/

1680/90 Analyzer - http://www.agilent.com/find/digitaldesign/

Software Updates - http://www.software.cos.agilent.com/1680-1690

Documentation
Web-based documentation - http://www.cos.agilent.com/manuals/

Intrinsic Support
Because the Agilent 1680A/AD-series products operate in a Microsoft Windows 2000
Professional environment, intrinsic support shall only cover the Agilent Logic Analyzer
application. Intrinsic support shall also cover any Windows 2000 Professional operating system
services utilized by the Agilent Logic Analyzer application:

� Print from the Agilent Logic Analyzer application.

� Networking.

� File management from the Agilent Logic Analyzer application.

Because the Agilent 1690A/AD-series products operate on a hosted desktop PC, support shall
only cover the Agilent Logic Analyzer application and the IEEE 1394 interface to the host PC.
Intrinsic support shall not cover any other Windows 2000 Professional operating system issues
other than those listed above. Other Windows 2000 Professional issues shall be considered
Microsoft issues.

Note:  Any customer-installed applications on an Agilent 1680A,AD-series product shall
not be supported by Agilent. Customers must contact the software vendor for support.

See Also
Tutorial - Getting to know your logic analyzer
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Table of 1680-series channel,
memory, and speed

Model Channel Count and Memory Depth

1680A 136-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep (full/half
channel)

Transitional timing: 200 MHz, 256K deep

1680A/D 136-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep

1681A 102-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep (full/half
channel)

Transitional timing: 200 MHz, 256K deep

1681A/D 102-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep

1682A 68-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep (full/half
channel)

Transitional timing: 200 MHz, 256K deep

1682A/D 68-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep

1683A 34-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep (full/half
channel)

Transitional timing: 200 MHz, 256K deep

1683A/D 34-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep
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Table of 1690-series channel,
memory, and speed

Model Channel Width and Memory Depth

1690A 136-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep
(full/half channel)

Transitional timing: 200 MHz, 256K deep

1690A/D 136-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep

1691A 102-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep
(full/half channel)

Transitional timing: 200 MHz, 256K deep

1691A/D 102-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep

1692A 68-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep
(full/half channel)

Transitional timing: 200 MHz, 256K deep

1692A/D 68-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep

1693A 34-channel

State: 200 MHz, 256 K deep

Timing: 400 MHz/800 MHz (full/half channel), 512 K/1 M deep
(full/half channel)

Transitional timing: 200 MHz, 256K deep

1693A/D 34-channel

State: 200 MHz, 1 M deep

Timing: 400 MHz/800 MHz (full/half channel), 2 M/4 M deep (full/half
channel)

Transitional timing: 200 MHz, 1 M deep
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Front Panel Operation
The front panel interface consist of knobs and buttons that you use to setup and run
measurements.  There are also shortcut buttons that quickly access commonly used
dialogs in the interface.

All functions available with the front panel knobs and buttons can also be performed in
the graphical user interface (GUI).  Unlike in the GUI, where you can block access by
disabling menus and toolbars, the front panel buttons/knobs cannot be blocked.
However, when a front panel action is not valid, an audible "beep" will sound.

Run/Stop

Item Description

Run Single Runs a single acquisition.  The Run Single button turns green indicating
when a Run action is valid.  While the analyzer is running, the light goes
out.

Run Rep.
(Repetitive)

Runs a repetitive acquisition.  The Run Repetitive button turns green
indicating when a Run Repetitive action is valid.  While the analyzer is
running, the light goes out.

Stop Stops the current acquisition. The Stop button turns red during a Run
cycle indicating when the Stop action is valid.

Save/Open Setup

Item Description

Open Setup Accesses the Open Configuration dialog.

Save Setup Accesses the Save Configuration dialog.

Default Setup Resets setup to the default power up configuration.

General purpose knob

The general purpose knob acts on the field that has the current focus.  Fields that have
the current focus have the blue background.  The general purpose knob is typically used
to increase/decrease numeric values such as waveform scale and delay.

Alphanumeric Keypad
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Item Description

Enter Accepts value or configuration change and exits dialog.

Tab Scrolls configuration fields left-to-right and top-to-bottom.

Backspace (left
arrow)

Backspaces cursor in an alphanumeric assignment field.

Esc In Ok/Cancel dialogs, the escape key acts as a cancel operation and exits
the dialog.

Keypad Used for alphanumeric entry.

Units Sets unit of measure.

Shortcuts

Item Description

Setup Accesses Buses/Signals tab in the Analyzer Setup dialog.

Waveform Accesses Waveform display window.  When the Waveform display is
active, the button turns green.

Listing Accesses Listing display window.  When the Listing display is active, the
button turns green.

Find Accesses advanced search dialog.

Trigger Accesses advanced trigger dialog.

File Mgr Accesses the Explore file manager dialog.

Print Accesses the Print dialog.

Help Accesses the online help system's main window.  Same as F1 key.

Vertical
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Item Description

Size Adjusts height of all waveform rows.  The selection lights up green
indicating it's part of the waveform group, and that the waveform group is
currently active.

Page Scrolls a page at a time of Listing data.  The selection lights up green
indicating it's part of the listing group, and that the listing group is currently
active.

Scroll Scrolls row at a time of Waveform data.  The selection lights up green
indicating it's part of the waveform group, and that the waveform group is
currently active.

Line Scrolls a line at a time of Listing data.  The selection lights up green
indicating it's part of the listing group, and that the listing group is
currently active.

Horizontal

Item Description

Time/Div Changes time/division scale of Waveform display.    The selection lights
up green indicating it's part of the waveform group, and that the
waveform group is currently active.

Bus/Sig Scrolls first column to last column in Listing Display.  The selection
lights up green indicating it's part of the listing group, and that the
listing group is currently active.

Delay Changes delay of Waveform display.    The selection lights up green
indicating it's part of the waveform group, and that the waveform
group is currently active.
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Column Scrolls a column at a time of  Listing data.  The selection lights up
green indicating it's part of the listing group, and that the listing group
is currently active.

Marker

Item Description

Move marker
knob

Moves selected marker in the display.

Choose marker
button

Selects marker for "Move" operation.  Press button to scroll through
available markers.  If no markers are defined, operating the knob an
Choose button will create an M1 marker for you.

For more marker information, refer to "Working with markers".
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Probing
The following probing options are available:

� General Purpose Probing (Standard)

� Adapter to board connectors (Optional)

� Analysis probes (Optional)

So far we've talked about some of the differences between scopes, timing and state
analyzers. Before we're ready to apply these new tools, we should talk about one more
subject – the probing system.

A scope probe is designed to gain easy access to the target system while minimizing the
signal distortion. Since we want to look at parametric information like voltage levels and
rise times, it is important that the probe doesn't load the circuit under test significantly. A
typical scope probe has 1 M ohm impedance shunted by 10 pF, depending on the
bandwidth required.

Logic analyzer probes are designed to allow connection of a high number of channels to
the target system easily by trading off amplitude accuracy of the signal under test.
Remember that a logic analyzer only distinguishes between two voltage levels!

Traditionally, logic analyzers used active probe pods, which had an integrated signal
detection circuitry for eight channels integrated. From these pods, we could connect with
leads to the circuit under test.

The typical impedance of a logic analyzer probe is in the area of 100 k ohm shunted by 8
pF at the input of the active pod. The connecting wires, however, add another 8 pF stray
capacitance, giving a total of 16 pF per channel.
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General Purpose Probing
Physical connections to digital systems must be reliable and convenient to deliver
accurate data to the logic analyzer with minimum intrusion to the target system.  The
standard general purpose probing solution shown below is shipped with the logic
analyzer.  Each channel is terminated at both ends with 100k ohm and 8 pF.

The standard set plugs directly into any .1-inch grid with 0.026 to 0.033-inch diameter
round pins or 0.025-inch square pins.  All probe tips work with the Agilent Technologies
5059-4356 surface mount grabbers and the Agilent Technologies 5959-0288 through-hole
grabbers.
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Adaptor to board connectors

Both the 01650-63203 and the E5346A adapters include termination for the logic
analyzer. The 01650-63203 termination adapter plugs into a 2 x 10 pin header with 0.1
inch spacing. The E5346A high-density adapter connects to an AMP "Mictor 38"
connector.

Analysis Probes
Connecting a state analyzer to a microprocessor system requires some effort in terms of
mechanical connection and clock selection. Remember, we have to clock the state
analyzer whenever data or addresses on the bus are valid. With some microprocessors it
might be necessary to use external circuitry to decode several signals to derive the clock
for the state analyzer.

Analysis probes (formerly called preprocessors) are microprocessor-specific interfaces
that make it easier to probe buses. Generally, analysis probes consist of a circuit board
that attaches to the microprocessor (possibly through an adapter) and a configuration
file. The configuration file sets up the logic analyzer's clocks, buses, and signals correctly,
and may include an inverse assembler. The circuit board provides access to logical groups
of pins through headers designed to connect directly to the logic analyzer.
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Self Tests
The Self Test menu checks the major hardware functions of the analyzer to verify that the
analyzer is working correctly.  A description of each test is found below.

If after completing the self tests you have failures, or you have questions about the
performance of the logic analyzer, contact Agilent Technologies sales or support at
http://www.agilent.com/find/contactus.

For more contact information, refer to Product overview.

To access self test menu
1. From the menu bar select Help>Self Test>Analyzer Self Test.

2. The first time the self test menu is accessed, a warning message comes up,
"Running self tests will invalidate acquired data."  Select OK to bring up the
menu.

3. Select either a single test or to run all tests.  As the test is running, test progress
is reported in the lower art of the dialog.

Self test descriptions
Register Test

Memory Test

Comparator Test

Trigger Bus Test

Trigger Arm Test

Clock Paths Test

Memory Modes Test

Calibration Test

Register Test
The Register Test verifies that the registers of each acquisition IC are operating properly.
Test patterns are written to each register on each acquisition IC, read, and compared
with known values. The registers are reset, and verified that each register has been
initialized. Test patterns are then written to ensure the chip address lines are not shorted
or opened. Finally test data is written to registers of individual acquisition ICs to ensure
each acquisition IC can be selected independently.

Passing the Register Test implies that the acquisition IC registers can store acquisition
control data to properly manage the operating of each IC.

Memory Test
The Memory Test verifies that each bit in the acquisition memory IC can be written with a
logic “0” and logic “1” through the Serial Access Memory port. Test data is generated
using a shifting test register in the acquisition ICs. The serialized test patterns are then
sent to the memory port of each acquisition memory IC and stored. The data in the
acquisition memory ICs are then downloaded and compared with known values.

Passing the Memory Test implies the acquisition memory can store data written through
the memory port. This test along with the Memory Modes Test provides complete testing
of the memory ICs.

Comparator Test
The Comparator Test ensures the data signal comparators in the module front end can be
set to their maximum and minimum thresholds and that they recognize activity at the
signal inputs. A clock signal is routed to a test port on each comparator. The threshold is
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then set to the minimum value. The comparator output is then read and compared with a
known value. The threshold is then set to a maximum value. The comparator output is
again read and compared with a known value.

Passing the Comparators Test implies that the front-end comparators are operating
properly, can recognize both a logic “0” and logic “1”, and can properly send the
acquisition data downstream to the acquisition ICs.

Trigger Bus Test
The Trigger Bus Test verifies the trigger resource lines that run between each acquisition
IC. The test ensures that the trigger resource lines can be both driven as outputs and
read as inputs. The resource registers are written with test patterns, read back, then
compared with known values. The resource registers are then written with test patterns,
read back from a different acquisition IC, then compared with known values.

Trigger Arm Test
The Trigger Arm Test verifies that the local arm signal can be received by the master
acquisition IC on the acquisition board. The test also verifies the global arm signal can be
driven by each acquisition IC on a master board and received by all acquisition ICs on the
card. The arm lines are asserted and read at the acquisition ICs to ensure each
acquisition IC recognizes the signal.

Passing the Trigger Arm Test implies any acquisition IC can arm the card and that all
acquisition ICs can recognize the arm signal.

Clock Paths Test
The Clock Paths Test verifies that the system Master, Slave, and Psync clocks are
functional between the acquisition ICs. The module is configured to take a simple
measurement. Test data is then created at the comparators and an acquisition taken. The
resulting data is then downloaded and compared with known values.

Passing the Clock Paths Test implies that all acquisition IC clock lines can be driven by
each acquisition IC and can be received by each acquisition IC in the module.
Consequently each acquisition IC can reliably acquire data in response to the acquisition
clock signal

Memory Modes Test
The Memory Modes Test verifies the CPU interface can properly manage the acquisition
memory unload in full-channel, half- channel, count only, and interleaved modes. Test
data is written to acquisition memory. Different unload modes are selected, then the data
is read and compared with known values.

Passing the Memory Modes Test implies that the data can be reliably read from
acquisition memory in full-channel, half-channel, count only, and interleaved mode. This
test along with the Memory Test provides complete testing of acquisition memory
downloading through the 1394 interface.

Calibration Test
The Calibration Test ensures that each acquisition IC in the module can perform an
operational accuracy self-calibration. Various self-calibration routines are initiated. The
results of each self-calibration routine are then checked to see if the self-calibration was
successful or not.

Passing the Calibration Test implies that the module can reliably perform an operational
accuracy self-calibration. Consequently the incoming data path is optimized to reduce
channel-to-channel skew so the acquisition ICs can reliably capture the incoming data.
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Menus

Menus
File Menu

Edit Menu

View Menu

Setup Menu

Tools Menu

Markers Menu

Run/Stop Menu

Window Menu

Help Menu
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File Menu

New Creates a new logic analyzer
configuration file.

Open Opens a previously saved logic analyzer
configuration file.  Secondary display
windows are not restored.

Close Closes the active window after asking
whether to save its data.

Save Saves changes to the currently open
configuration file.

Save As Saves the currently open configuration
file to a new name.

Print Prints displayed data within a defined
range.

Export Exports data in a defined range.

Import Imports a defined file.

Recent Configuration Files Lists recently opened files for quick
reference or access.

Exit Closes the logic analyzer user interface
window.
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Edit Menu

Undo Undo the last user action.  This includes any properties that have changed such as column
color, column width, column move, column insert, column delete, etc.  Items that cannot be
undone include scrolling, acquisition runs and simple trigger modifications.

Cut Cuts the selection from alphanumeric fields in listing and waveform windows.  Alphanumeric
fields in lower level modal dialogs are cut using keyboard commands (accelerator keys).  Cut
selections are pasted to the clipboard.

Copy Copies the selection from alphanumeric fields in listing and waveform windows.  Alphanumer
fields in lower level modal dialogs are copied using keyboard commands (accelerator keys).
Copied selections are pasted to the clipboard.

Copy
Screen

Copies the current screen to a bitmap and places it on the system clip board.

Paste Pastes the cut or copied data that is stored in the clipboard into the alphanumeric field.
Alphanumeric data is pasted into fields in lower level modal dialogs using keyboard
commands (accelerator keys).

Insert
Bus/Signal
Into
Window

Inserts a predefined bus or signal into the display.

Remove
Bus/Signal

Deletes the highlighted bus or signal from the display window.
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From
Window

Window
Properties

Accesses the window properties dialog.

Symbols Accesses the Symbols dialog.

Find Locates specific data in the acquisition.

Find
Previous

Locates the previous occurrence of the specified data.

Find Next Locates the next occurrence of the specified data.

Go To
beginning

Places the beginning of the captured data trace at center screen.

Go To
Trigger

Places the trigger point at center screen.

Go To End Places the end of the captured data trace at center screen.

Go To Accesses the Go To selection list.

Options Accesses the System Options dialog.



241

View Menu

Zoom Out Zooms out on an active window.

Zoom In Zooms in on an active window.

Toolbars Access the Toolbar dialog window.

Full Screen Enables or disables full screen display.

Tabbed Windows Enables or disables Listing and Waveform
tabs.

Status Bar Enables or disables the status bar.
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Setup Menu

Bus/Signal Accesses the Bus/Signal setup dialog.

Timing/State (Sampling) Accesses the Sampling setup dialog.

Simple Trigger See "Simple Trigger".

Advanced Trigger Accesses the Advanced Trigger dialog.

Store Trigger Stores current trigger.

Recall Trigger Accesses a list of most recently used
triggers.

Symbols Accesses the Symbols dialog.
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Tools Menu

All add-in tools are grouped under the tools menu.  Your Agilent Logic Analyzer comes
with a filter/colorize tool built in.  If you are using inverse assemblers, bus analysis tools,
or other third-party tools, the tools will show up in the Tools menu under New.

As tools are created, they are added to the top of the Tools menu.  The menu above
shows one active tool.

1 tool name Edit an existing tool.

New Creates a new analysis tool.

Overview Lets you manage the active tools.

Find Locates specific data in the acquisition.

See Also
To add a new tool

To change a tool

To delete a tool

To filter or colorize data
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Markers Menu

New Creates a new marker.

Place on Screen Places a selected marker on screen over
the trigger point.

Go To Goes to a selected marker.

Center About Centers the display around a selected
marker.

Delete Deletes selected markers.

New Interval Measurement Creates a new interval measurement.

New Value At Measurement Creates a new value at measurement.

Hide Measurements List Hides the marker measurement display
bar.

Properties Accesses the markers properties dialog
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Run/Stop Menu

Run Starts sampling, fills logic analyzer
memory with samples around the trigger,
and stops.

Run Repetitive Starts sampling, fills logic analyzer
memory with samples around the trigger,
and repeats.

Stop Stops a logic analyzer measurement that
is in progress.

Cancel Cancels the current Run.

Resume Resumes the current Run after a Cancel.
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Window Menu

New Listing Creates an additional listing window.

New Waveform Creates an additional waveform window.

Rename Allows the user to change the active
window name.

Properties Accesses the display properties dialog.

Close Closes the active window.

Next Displays the next window.

Previous Displays the previous window.

Cascade Displays all opened windows in an
overlaid and offset format.

Tile Horizontally Displays all opened windows so the
horizontal display space is equally
divided.

Tile Vertically Displays all opened windows so the
vertical display space is equally divided.

Arrange Icons All minimized listing and waveform
windows are arranged at the bottom of
the analyzer window.

1.

2.

Lists all open display windows for
reference or access.
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Help Menu

Help Topics Accesses the online help.

Help On Viewers Opens online help for either the Listing or
Waveform window.

Help On AddIns Opens online help for AddIns.

Self Test Accesses the Logic Analyzer Self-Tests
dialog.

Status Log Accesses the Info Manager dialog.

About Displays product version and copyright
information.
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Toolbars

Toolbars
Toolbars are located under the menu bar, and are used to quickly access a function or
perform a task.  By default, not all toolbars, or individual tools within a given toolbar are
displayed. For a complete list of all available toolbars, click View>Toolbars>.  For a
complete list of all tools within a given toolbar, click
View>Toolbars>Customize>Commands.

Standard

Setup

Markers

Run/Stop

Viewers

Customize
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Standard Toolbar

New - Creates a new logic analyzer configuration file.

Open - Opens a previously saved logic analyzer configuration file.  Secondary display
windows are not restored.

Save - Saves changes to the currently open configuration file.

Print - Prints displayed data within a defined range.

Find - Locates specific data in the acquisition.

Find Previous - Locates the previous occurrence of the specified data.

Find Next - Locates the next occurrence of the specified data.

Go to Beginning - Centers the beginning of the acquisition data.

Go to Trigger - Centers the trigger point of the acquisition.

Go to End - Centers the end of the acquisition data.

Zoom Out - Zooms in on an active window.

Zoom In - Zooms out on an active window.

Tools Overview - Shows an overview of the current Tools.

Note: The following are optional standard toolbar icons.

Cuts the selection and places it on the clipboard.

Copies the selection and places it on the clipboard.

Pastes the data that is stored on the clipboard.

Provides information about the Agilent 16xx Product.

Undo last user action.

Enables or disables full screen display.
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Activate the next window.

Activates the previous window.

Arranges windows as overlapping tiles.

Arranges windows as non-overlapping horizontal tiles.

Arranges windows as non-overlapping vertical tiles.

See Also
To create a custom toolbar
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Setup Toolbar

Bus/Signal - Accesses the Bus/Signal setup dialog.

Timing/State (Sampling) - Accesses the Sampling setup dialog.

Advanced Trigger - Accesses the Advanced Trigger dialog.

See Also
To create a custom toolbar
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Markers Toolbar

New - Creates a new marker.

Go To - Centers the display around the selected marker.

Creates a new interval measurement.

Creates a new value at a measurement.

Note: The following are optional markers toolbar icons.

Place Maker - Places the selected marker on the screen.

Center About - Centers the display around two selected markers.

Turns the marker measurement list on and off.

Accesses the markers properties dialog.

See Also
To create a custom toolbar
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Run/Stop Toolbar

Starts sampling, fills logic analyzer memory with samples.

Starts Sampling, fills logic analyzer memory with samples around the trigger, and
repeats.

Stops a logic analyzer measurement in progress, for example, when the trigger
condition is not found.

Stops the current action.

Resumes the cancelled action.

See Also
To create a custom toolbar
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Viewers Toolbar

Creates a new listing viewer.

Creates a new waveform viewer.

See Also
To create a custom toolbar
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To create a custom toolbar
To add tool icons

1. From the menu bar, select View>Toolbars.

2. Click Customize, then select the Commands tab.

3. Select the toolbar you wish to customize.

4. Drag the desired icon to the correct position on the selected toolbar. Release the
mouse button to insert the tool icon.

5. Repeat for any other icons you wish to add.

6. Select OK.

To remove tool icons
1. From the menu bar, select View>Toolbars.

2. Click Customize, then select the Commands tab.

3. Select the toolbar you wish to customize.

4. Drag the icon from the toolbar and drop it onto the Customize dialog box.

5. Repeat for any other icons you wish to remove.

6. Select OK.
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Windows

Windows
Listing Display Window

Waveform Display Window

See Also

Viewers Toolbar
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Dialogs

Dialogs
Buses/Signals Setup

Sampling Setup

Printing Data

Advanced Trigger

Exporting Files

Importing Files

System Options

Recall Trigger

Waveform Window Properties

Listing Window Properties

Markers Properties

Symbol Selection

Symbols

Filter/Colorize

Tool Overview
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Analyzer Setup Dialog

Analyzer Setup Dialog

The Analyzer Setup dialog is accessed through the menu bar's Setup>Bus/Signal.

The dialog consists of the following two tabs.

Buses/Signal

The Buses/Signals tab is used to map bus and signal names in the interface to the pod
and channel connections of the probes.  Also, you can set a pod threshold, and assign a
numeric base and polarity to the bus or signal.

Sampling

The Sampling tab is used to name the analyzer, and select and configure the acquisition
mode.  In the Timing Acquisition Mode, you set the channel width and sampling rate.  In
the State Acquisition Mode you configure the state clocks and qualifiers.
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System Options Dialog

To change your system options, select Edit>Options from the menu bar.  System
options are written in the Windows registry file and persist across sessions.

To change how many triggers are saved
Set the Trigger History Depth.  You can keep as many as 50 of the most recently used
triggers.  See To store a trigger for more information on re-using triggers.  Trigger
history is saved in the configuration files.  The default is 10.

To change the length of the file history
Set the Recent File List Size.  This sets how many recently-loaded configuration files
are shown in the File menu.  The default is 4.

To create data when offline
Check the Create Data When Offline box.  When you run the analyzer, fake data will be
created.  This mode is useful when learning how to use the logic analyzer software.

Note:  The logic analyzer does not trigger with fake data.  You can set the triggers, but
will not get the same results you would with a real acquisition.

To set Trigger In and Trigger Out
Trigger In allows you to trigger the logic analyzer from another source.  It expects to see a
TTL signal, not to exceed 5.5 volts, with a minimum signal amplitude of 500 mV.
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Trigger Out sends a signal to another device when the logic analyzer triggers.  Low is 0 volts,
high is 3.3 volts.

To set message level
As with any other program, the Agilent Logic Analyzer generates messages about events.
You can choose which messages are displayed.  Check the appropriate box to indicate
you wish the dialogs displayed.

Show Information
Dialogs

Information dialogs offer tips such as the location of Simple
Trigger, and do not indicate a failure.

Show Warning Dialogs Warning dialogs occur when some setting may affect your data,
such as being offline.

Show Error Dialogs Error dialogs occur when an operation cannot be completed as
specified.

Event Logging You can choose to have all events recorded in a log file.  Event
logging will slow down your logic analyzer.  Event logs can be
viewed through Help>Status Log. Set the event logging level
according to the directions of your Agilent Technologies support
person.  Be sure to turn off event logging when resuming normal
use.
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Properties Dialog

Properties Dialog

The Properties dialog is accessed through the menu bar's Window>Properties. Use it to
setup how the window and the displayed data appear.

To set waveform window properties

To set waveform display properties

To set listing window properties

To set listing column properties

To set marker properties
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Symbol Selection
Use the Select Symbol dialog to choose a symbol to use when the numeric base is set to
Symbols.

To choose a symbol:

1. Look for the bus for which the symbol is defined.

2. Select the symbol.

If the symbol you want is not listed, you can:

� Check that you are looking at the right bus, or

� Load a configuration file in which the symbol is defined. or

� Add the symbol.

The Select Symbol dialog is used whenever you need to choose a symbol. For example,
the Select Symbol dialog will be displayed when you use the Symbols numeric base in the
following dialogs:

� Find

� Filter/Colorize

� Simple Trigger

� Advanced Trigger Dialog
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Specifications and Characteristics

Specifications and Characteristics
Describes the specifications, characteristics, and requirements of the 1680A/AD-series
and 1690A/AD-series logic analyzers.

� 1680A-Series Logic Analyzer Specifications

� 1680A-Series Logic Analyzer Characteristics

� 1690A-Series Logic Analyzer Specifications

� 1690A-Series Logic Analyzer Characteristics

� About the Probe Cable

� Signal Requirements

See Also
� What is a Specification

� What is a Characteristic
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1680/1690-Series Logic Analyzer
Characteristics

� General Information

� Probes

� State Analysis

� Timing Analysis

� Triggering

� Operating Environment Characteristics

General Information
State/timing
channels:

34, 68, 102, and 136

Memory
depth:

200 MHz State: A model = 256K; AD model = 1M
 400 MHz Timing (full channel): A model = 512K; AD model = 2M
 800 MHz Timing (half channel): A model = 1M; AD model = 4M
 200 MHz Transitional Timing: A model = 256K; AD model = 1M

User
interface:

Windows® 2000 Professional

Printers: Can print to any local or network printer supported by Windows® 2000
Professional.

Dimensions: 1680 - 257 mm height (10.14 in), 443 mm width (17.45 in), 385 mm
depth (15.15 in)

1690 - 153 mm height (6.05 in), 438 mm width (17.23 in), 335 mm depth
(13.16 in)

Weight: 1680 - 13.2 kg (29.1 lbs)

1690 - 7.5 kg (16.5 lbs)

Probes
Input resistance: 100 kohm ±2%

Resistive tip capacitance: 1.5 pF

Minimum input voltage swing: 500 mV peak-to-peak

Maximum input voltage: ±40 V peak

State Analysis
Maximum State Speed 200 MHz

Minimum state clock pulse width: 1.2 ns

Time tag resolution: 4ns or ±0.1% (whichever is greater)

Maximum time count between states: 17 seconds

State clock/qualifiers 4 (2 on 34 channel models)

Timing Analysis
Maximum timing sample rate: 400 MHz/800 MHz

Sample period accuracy: ±0.01% of sample period ±100 ps

Channel-to-channel skew: <1.5 ns typical

Timing interval accuracy: ±(sample period accuracy + channel-to-channel skew
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+ 0.01% of time interval reading)

Triggering
Sequencer speed: 200 MHz

Occurrence counters: 1 per sequence level

Trigger sequence levels: 16

Operating Environment Characteristics
Temperature: Instrument: 5°C to 50°C

Disk media: 10°C to 40°C

Probe lead sets and cables: 0°C to 65°C

Humidity: Instrument: Up to 95% relative humidity at 40°C

Disc media and hard drive: 8% to 85% relative humidity

Altitude: 4,572 m (15,000 ft) operating

15,300 m (50,000 ft) non-operating



266

1680/90A-Series Logic Analyzer
Specifications

Threshold Accuracy ±(65 mV +1.5 % of setting)

Minimum Master-
to-Master Clock
Time

5.0 ns

Setup/Hold Time
(Single Clock,
Single Edge)

2.5 ns window adjustable from 4.5/-2.0 ns to -2.0/4.5 ns
in 100 ps increments per channel

Setup/Hold Time
(Multiple Clock,
Multiple Edge)

3.0 ns window adjustable from 5.0/-2.0 ns to -1.5/4.5 ns
in 100 ps increments per channel
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About the Probe Cable
The probe cable contains 16 signal lines, 1 clock line, 20 ground lines, 1 serial line for
communication with analysis probes, and 2 lines that carry minimal power for demo
"device under test" systems.

The cable ground lines are chassis (earth) grounds and not "floating" grounds. All the
lines are woven into a flat ribbon that is 4.5 feet long.  See Probing in the Quick
Start/Installation Guide for the cable pinout and equivalent load.

Caution:  Do not exceed 0.33 amps per cable, or the cable will be damaged.
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Signal Requirements
� Minimum Signal Amplitude

� Signal Loading

� Maximum Probe Input Voltage

� Overdrive

Minimum Signal Amplitude
Any signal line you intend to probe with the logic analyzer probes must supply a minimum
voltage swing of 500 mV to the probe tip. If you measure signal lines with a smaller
voltage swing, you may not get reliable results. The minimum input overdrive is the
greater of 250 mV or 30% of signal amplitude.

Signal Loading
Any probed signal line must be able to handle the following load:

If  the signal cannot handle this load, the target system may malfunction.

Maximum Probe Input Voltage
The maximum probe input voltage of each logic analyzer probe is 40 volts peak.

Overdrive
Overdrive is the amount a signal must exceed the threshold voltage for the logic analyzer
to detect a change in logic level. For the 1680-series logic analyzer, overdrive is 250 mV
or 30% of signal peak-to-peak amplitude, whichever is greater.

For example, given a 3.3 volt CMOS signal (low = 0V, high = 3.3 V) the optimal threshold
is 1.65 V (50%). If the threshold is set less than 1.0 V or greater than 2.3 V, then a
timing acquisition might show excessive channel-to-channel skew. For a state acquisition,
the analyzer's setup and hold requirements might not be met.

The overdrive amount is specified as the greater of 250 mV or 30% of the signal
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amplitude because it has two purposes. The 250 mV ensures reliable switching or state
detection. The 30% of amplitude ensures the threshold is reasonably centered within the
waveform in order to minimize channel-to-channel skew (tPHL vs tPLH).
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What is a Specification?
A specification is a numeric value, or range of values, that bounds the performance of a
product parameter.  The product warranty covers the performance of parameters
described by specifications.  Products shipped from the factory meet all specifications.
Additionally, products sent to Agilent Customer Service Centers for calibration, and
returned, meet all specifications.  Specifications are verified by calibration procedures.

What is a Calibration Procedure?
Calibration procedures verify that products or systems operate within the specifications.
Parameters covered by specifications have a corresponding calibration procedure.
Calibration procedures include both performance tests and system verification procedure.
Calibration procedures are traceable and must specify adequate calibration standards.

Calibration procedures verify products meet the specifications by comparing measured
parameters against a pass-fail limit. The pass-fail limit is the specification less any
required guardband.

The term "calibration" refers to the process of measuring parameters and referencing the
measurement to a calibration standard rather than the process of adjusting products for
optimal performance.

Note: Self-tests are not a substitute for calibration.

See Also
What is a Characteristic
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What is a Characteristic?
Characteristics describe product performance that is useful in the application of the
product, but that is not covered by the product warranty.  Characteristics describe
performance that is typical of the majority of a given product, but not subject to the
same rigor associated with specifications.  Characteristics are verified by function tests.

What is a Function Test?
Function tests are quick tests designed to verify basic operation of a product.   Function
tests include operator's checks and operation verification procedures.   An operator's
check is normally a fast test used to verify basic operation of a product. An operation
verification procedure verifies some, but not all, specifications, and often at a lower
confidence level than a calibration procedure.

See Also
What is a Specification
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Markers Display Bar

To access these tasks, right-click anywhere in the marker display bar.

New - To create new markers.

Place - To place markers in data.

Go To - Go To a marker.

Center About - To center the display about a marker.

Delete - To delete a marker.

Delete All - To delete all makers.

Rename - To rename a marker

Send to back - To send a marker to the back

Properties - To set marker properties.

See Also
Reading off-screen markers

Markers menu

Markers toolbar
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Marker Measurement Display Bar
Marker "interval" and "value at" measurements are displayed below the menu bar with
the other toolbars.

To create a new interval measurement

To create a new value at measurement

To hide/show measurement display bar
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Config Translator Application

Config Translator is a helper application for the Agilent Logic Analyzer.  In the first
release, shipped with your logic analyzer, it only translates 1670G-series Logic Analyzer
configuration files.  You can download updates along with updated logic analyzer software
at our website, http://software.cos.agilent.com/1680_1690/.

To run Config Translator, select the Agilent Logic Analyzer menu from the Windows2000
Start bar.  Config Translator can be run without any logic analyzer hardware.

To convert a configuration file

1. Open Config Translator by selecting Start>Programs>Agilent Logic
Analyzer>Agilent 167xG Config Translator.

2. Type in the name of the configuration file you want to convert.  Use the ... button
to browse if you are unsure of the name.

Note: 167xG configuration files end in ._A, but this suffix is also used by other models.
If possible, confirm that it has a file type of 167xdn_config when viewed on a 1670-series
logic analyzer.

 Only setup information is translated, not saved data.

3. Type in the name you want to save the new configuration files under.

1. Because the 1670-series logic analyzers split resources between two measurement
engines by default, two output files are created.  The default filename is the same as
the 167xG configuration file, but has 1.txt or 2.txt appended.  Both files are created
even if the configuration only used one of the measurement engines.

2. Files are saved in the same directory as the input file unless otherwise specified.

3. The output files are in XML format, and can be imported like other XML files.

4. Select Convert.
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Information not converted from file
� In timing acquisition mode, the sampling period and sampling option.

� In state acquisition mode, the clock mode and clock description.

� All data.

� Any tool information.

� Interface layout.

� Marker information.

See Also
XML Format

To import files
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Error Messages
To locate the error you received, use ctrl+F and search for a key word.

Error messages

Warning messages

Informational messages

Error messages
Acquisition errors

An acquisition error has occurred due to state clock edges
occurring too close together. This could be the result of:    -
Poor state clock quality (signal integrity).   - Inadequate
probe grounding (try multiple grounds around clock signals).
- State clock edges spaced closer than specifications allow.  -
Multiple clocks selected and spaced closer than specifications
allow.

 When in the state acquisition mode, the logic analyzer requires a clear clock signal no
faster than 200 MHz (edges at least 2.5 ns apart).  Poor state clock quality may be
caused by loading on the target system. It may also be caused by a clock setup in the
Sampling Menu that is a combination of several signals which combined together violate
the clock specification.  When your clock setup uses multiple edges, the analyzer cannot
sample faster than 3.0 ns.  When you are using a clock speed near the specification,
grounding every second or third probe connection is recommended.

Bus/Signal errors
Maximum of 128 channels per Bus.

The logic analyzer cannot handle buses that contain more than 128 channels (signals).  If
you require wider buses, try breaking the bus into two or more buses, for example
Data_HI and Data_LO.

Cannot group into Bus. Maximum of 128 channels per Bus.
The logic analyzer cannot handle buses that contain more than 128 channels (signals).  If
you require wider buses, try breaking the bus into two or more buses, for example
Data_HI and Data_LO.

The following Bus/Signals are required to have a specific
number of assigned channels because they are locked.
Please correct the following Bus/Signals: name (has num1
channels, requires num2 channels)

Some tools may "lock" buses and signals that are necessary to produce their output.  The
locked buses and signals may have their specific channel assignments changed, but the
total number of channels on each bus or signal must stay the same.  Please change the
channel assignment for each indicated bus or signal so that the width is num2.  This
message sometimes appears in combination with the next one.  In these cases, you may
have changed a configuration to use half the pods for sampling.  Check the sampling tab.

Every Bus/Signal requires at least one assigned channel.
Please assign channels to the following Bus/Signals:

Every bus or signal requires at least one channel.  If you do not see the Bus/Signal
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named in the error dialog, try scrolling the Bus/Signal listing.  Certain tools may also
have created buses or signals within folders.  If you are trying to avoid showing extra
information on the viewer, delete the row or column the bus or signal is in.  This removes
the information from the viewer without losing the bus/signal setup information.  This
message sometimes appears in combination with the previous one.  In these cases, you
may have changed a configuration to use half the pods for sampling.  Check the sampling
tab.

Minimum of one Bus/Signal with assigned channels required.
Please add a Bus/Signal.

The bus/signal setup cannot be closed because you have deleted all buses and signals.
Folders only contain buses and signals, but do not represent data mappings of
themselves.  In order to close the dialog, select Add Bus/Signal.  Assign at least one
channel to the new bus or signal.  Alternatively, you can select Cancel  and revert to the
previous bus and signal assignments.

name is locked and cannot be deleted because it is required
by another tool in the application.  In order to unlock it, the
following tools must be deleted: tool

Some tools may "lock" buses and signals that are necessary to produce their output.
Until the tool is deleted via Tools>Overview, you cannot delete or rename the bus or
signal.

name is locked and cannot be renamed because it is required
by another tool in the application.  In order to unlock it, the
following tools must be deleted: tool

Some tools may "lock" buses and signals that are necessary to produce their output.
Until the tool is deleted via Tools>Overview, you cannot delete or rename the bus or
signal.

Cannot change pod selection while there are locked
Bus/Signals.

Some tools may "lock" buses and signals that are necessary to produce their output.
Until the tool is deleted via Tools>Overview, you cannot modify the bus or signal by
changing the pod in use.

Cannot delete folder because it contains one or more locked
children.

Some tools may "lock" buses and signals that are necessary to produce their output.  The
folder you have tried to delete contains a unique copy of at least one locked bus or signal.
You can move the locked buses or signals outside the folder, and then delete the folder.
Alternatively, you can delete the tool locking the buses or signals via Tools>Overview,
and then delete the folder.

Unable to set setup and hold times for this Bus/Signal since
no channels have been assigned.  Please assign channels
before using setup and hold.

The possible valid range of setup and hold values depends on the clock setup used by the
pods that the channels are attached to.  Without knowing which pods' channels are part
of the bus or signal, it is impossible for the logic analyzer to set appropriate ranges.
Please assign channels to the bus or signal, and then set setup and hold.

Please enter a user threshold value.
All pods will be set to the same threshold value.  If you select OK without setting a value,
the current threshold values (at least one of which is different from the rest) are retained.
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Please check the dialog and be sure all fields are filled in.

Please enter a threshold value.
All pods will be set to the same threshold value.  If you select OK without setting a value,
the current threshold values (at least one of which is different from the rest) are retained.
Please check the dialog and be sure all fields are filled in.

File errors
Error trying to remove file: "directory/hardware_log.txt".

When the logic analyzer is started up, it replaces the old hardware_log.txt file.  For some
reason, this time the old hardware log was not able to be deleted.  This could indicate a
problem with the disk that the file is stored on.

File "filename" could not be opened.
When the logic analyzer is started up, it creates a new hardware_log.txt file.  For some
reason, this time the log was not able to be opened after creation.  This could indicate a
file system or disk problem.

Hardware errors
Analyzer Calibration Failed [time] - Instrument may need
service

The logic analyzer's pre-measurement calibration failed.  Any data collected after
receiving this error message is possibly incorrect.  If the failure is transient, cycling power
may fix the problem.  If the failure is persistent, run Help>Self-test>Analyzer self-
test or call your Agilent Sales Office to arrange for service.

High speed system clock failure - Instrument may need
service.  Sleep Duration and Count: duration, counted

The internal 100 MHz clock did not pass initialization tests.  Any measurements are likely
to be faulty.  Please contact Agilent Technologies sales or support at
http://www.agilent.com/find/contactus for information on getting the instrument
repaired.

Contact with the analyzer hardware has been lost. This
application will be terminated. You will have an opportunity
to save your configuration.

[1690A-series analyzers only]  Something has interrupted the IEEE-1394 connection
between the computer and the logic analyzer.  Save your current work in a configuration
(*.ala) file, then check the power to the logic analyzer hardware and the connections.   A
lost connection cannot be resumed; you will need to re-start the logic analyzer
application.

I/O Channel Error: Invalid Request Argument.
[1690A-series analyzers only]  There is a problem with the data being sent via the IEEE-
1394 connection.

I/O Channel Error: Offset Out of Bounds.
[1690A-series analyzers only]  There is a problem with the data being sent via the IEEE-
1394 connection.

I/O Channel Error: Timeout.
[1690A-series analyzers only]  There is a problem with the data being sent via the IEEE-
1394 connection.

I/O Channel Error: System I/O Error.
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[1690A-series analyzers only]  There is a problem with the data being sent via the IEEE-
1394 connection.

I/O Channel Error.
[1690A-series analyzers only]  There is an unspecified problem with the data being sent
via the IEEE-1394 connection.

Help file errors
Help file information was not found in the registry.  You may
need to reinstall the tool.

The logic analyzer could not find a registry entry for the help file associated with the tool.
If you have done a custom installation of the tool, you must also install the help file to
access help.  If the problem persists after re-installing, please contact Agilent
Technologies sales or support at http://www.agilent.com/find/contactus for assistance.

Help file information not found in registry. Cannot display
help.

The logic analyzer could not find a registry entry for the help file associated with the tool.
If you have done a custom installation of the tool, you must also install the help file to
access help.  If the problem persists after re-installing, please contact Agilent
Technologies sales or support at http://www.agilent.com/find/contactus  for assistance.

Help file not found.  Cannot display help.
The help file was not found where specified by the registry.  It may have been deleted or
moved.  You can search the drive where the logic analyzer software is installed for .chm
files, or re-install the tool.

The HTML Help file "filename" was not found.  You may need
to re-install the product.

The help file was not found where specified by the registry.  It may have been deleted or
moved.  You can search the drive where the logic analyzer software is installed for the
file, or re-install.  To re-install, close the logic analyzer application and run the setup
program on the logic analyzer CD.

The HTML Help file "filename" was not found.  You may need
to re-install the tool.

The help file for the tool was not found where specified by the registry.  It may have been
deleted or moved.  You can search the drive where the logic analyzer software is installed
for .chm files, or re-install the tool.

Import/Export and Translator errors
Refer to the import files: file1 and file2 for more details.

The configuration translator could not complete the translation.  An explanation will be
listed in file1 or file2 between "<!--" and ">" delimiters.

The specified file is NOT a 167xG Analyzer configuration file:
filename

The configuration translator was not able to translate the specified file because it was not
in an understood format.  The configuration translator only translates configuration files
generated by 1670G, 1671G, 1672G, and 1673G logic analyzers.

Cannot read configuration file filename
The configuration translator was unable to read the configuration file indicated due to an
internal error in the configuration file.
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Cannot import an empty file.  Import terminated.
The file you tried to import has no content.

Invalid non-ascii character read.  Import terminated.
The logic analyzer only imports ASCII files.  The file you tried to import contains a non-
ascii character.  You can edit the file in any text editing program, such as Notepad, to
remove the character.  Be careful to not change header data or the number of samples.

There are one or more locked bus/signals required by tool(s)
currently loaded in the application.  In order to unlock any of
these bus/signals, you must unload every tool listed for that
bus/signal. ... Import terminated.

Some tools may "lock" buses and signals that are necessary to produce their output.
Until the tool is deleted via Tools>Overview, you cannot delete, rename, or modify the
bus or signal.  A side effect of this is that you cannot import a file that uses different
buses and signals, or analyzer channel count.

There were fewer time data samples than indicated by the
NumberOfSamples attribute of Module tag.  Import
terminated.

When you import a saved data file, the logic analyzer verifies that the data is consistent.
To fix this error, you can edit the file in any text editing program, such as Notepad.

Syntax error in import file: error.  Import terminated.
The error description indicates the syntax problem.  Most often, it results from
mismatched tags.  Check the import file for any accidental deletions.

No bus/signals were valid for importing.  Import terminated.
The import file was created on a logic analyzer model with more pod pairs than this one,
and all the buses and signals were defined on pod pairs this model does not possess.  You
can attempt to modify the file by changing the assigned channels for the buses and
signals.  You can use any text editing program (such as Notepad) to edit import files.  For
more information on the format of import files, see XML Format .

Could not create file for export
The logic analyzer was unable to create the file.  Possible reasons include not enough disk
space or insufficient permissions to create the file where indicated.

Could not find required tag1 section contained within tag2
section

The import file is required to have a section with the heading tag1 completely contained
within the section delimited by <tag2> and </tag2>.  You can repair the import file by
adding <tag1></tag1> at the beginning of the tag2 section.  You can use any text
editing program (such as Notepad) to edit import files.  For more information on the
format of import files, see XML Format .

Invalid or missing attribute attribute in tag XML tag
The import file requires the XML tag tag to include the keyword attribute and a value.  For
example, if attribute is Acquisition and tag is Sampling, the file has an XML tag of the
form <Sampling></Sampling> but requires <Sampling
Acquisition="State"></Sampling>.  You can repair the import file by adding attribute
to the specified tag and giving it a value.  (Try exporting a similar configuration to see
standard values.)   You can use any text editing program (such as Notepad) to edit
import files.  For more information on the format of import files, see XML Format .

Invalid attribute value for attribute attribute  in tag XML tag
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The import file requires the XML tag tag to include the keyword attribute and a value.  For
example, if attribute is Acquisition and tag is Sampling, the file might have an XML tag of
the form <Sampling Acquisition="Time"></Sampling> but requires <Sampling
Acquisition="Timing"></Sampling>.  You can repair the import file by editing the
value.  (Try exporting a similar configuration to see standard values.)   You can use any
text editing program (such as Notepad) to edit import files.  For more information on the
format of import files, see XML Format .

Naming errors
To edit channel assignment, click on the pod cells to the
right.

This error occurs when you select the Channels Assigned column in Bus/Signal setup.
This column is for reference only.  To assign channels to a bus or signal, use the grid to
the right.  For more detail on channel assignment, see To assign channels .  To hide the
Channels Assigned column, select Display> Channels Assigned in the Buses/Signals
setup tab.

The object name cannot be an empty string.
When you rename a viewer, tool, or bus, you must give it a name at least one character
in length.  The blank or empty name you tried was not accepted by the logic analyzer.

Object name must be unique.
You have tried to rename a viewer, tool, or bus, but the name you entered is already
being used and so was not accepted by the logic analyzer.   You may appear to have
identical names on some buses or signals, but these either are truncated or refer to the
same bus (aliases).

The name "toolname" is already in use.  Please choose a
different name.

You have tried to rename a tool, but the name you selected is already in use.  If you do
not rename the tool, it will revert back to its previous name when you close the Tool
Overview dialog.

Tool errors
For errors generated by specific inverse assemblers or bus analysis tools, go to the
appropriate tool help.

Could not load the component - you may need to reinstall
This error occurs when there is a problem with the tool file.  Possible reasons are the tool
file was renamed, or permissions changed so that the logic analyzer cannot open it.  To
reinstall the tool file, close the logic analyzer and run the setup program on the logic
analyzer CD.

Could not get license information for component
The logic analyzer attempted to determine if the tool was licensed or freely available, but
could not find the information.  Try re-installing the tool.

Could not obtain license information for component
This error means the logic analyzer is missing some information it needs in order to check
the license.  Licenses are created by the lmtools.exe program.  You can run this to see
what information is missing, and to check licenses.

Could not obtain a license for component
This error occurs when the license is not in the expected directory.  When the tool is
installed, the license is written into a predefined directory.  Moving or deleting the file
prevents you from using the component.  If you do not believe the license was deleted,
check your hard drive for *.lic files.
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License for component is invalid
This error means that a license file exists, but that the information in it does not match.
Licenses are specific to equipment; you cannot transfer a license for a tool or a logic
analyzer between tools or logic analyzers.

Could not create licensed component
There was a valid license for the tool earlier in the install process, but something has
gone wrong.  Start the tool installation process over again.  If this error persists, please
contact Agilent Technologies sales or support at http://www.agilent.com/find/contactus
for assistance.

Could not create component - unknown error
A license for the tool exists in the proper directory, but the internal information is
inconsistent.  Licenses are specific to equipment; you cannot transfer a license between
tools or between logic analyzers.  If this is a corrupt license, try reinstalling the tool
again.

The stored tool could not be restored from file. The tool may
have been uninstalled.

The configuration file you are trying to load includes a licensed tool.  The logic analyzer
was not able to find this tool, so some information will be missing.  All buses and signals
that were based on physical data will be loaded; buses and signals created by the tool will
not.

The selected tool: Name could not be loaded.
The configuration file you are trying to load includes a licensed tool.  The logic analyzer
was not able to find this tool, so some information will be missing.  All buses and signals
that were based on physical data will be loaded; buses and signals created by the tool will
not.

The selected tool could not be loaded.
The configuration file you are trying to load includes a licensed tool.  The logic analyzer
was not able to find this tool, so some information will be missing.  All buses and signals
that were based on physical data will be loaded; buses and signals created by the tool will
not.

The tool could not be created - you may need to reinstall the
tool.

The configuration file you are trying to load includes a licensed tool.  The logic analyzer
was not able to find this tool, so some information will be missing.  All buses and signals
that were based on physical data will be loaded; buses and signals created by the tool will
not.

The analysis tool (toolname) could not be restored from the
configuration file.

The configuration file you are trying to load includes a licensed tool.  The logic analyzer
was not able to find this tool, so some information will be missing.  All buses and signals
that were based on physical data will be loaded; buses and signals created by the tool will
not.

Trigger Errors
Only one action per timer per branch is allowed.

A branch is the collection of actions after a "Then" in an Advanced Trigger step.  Some
steps, such as  Advanced 2-Way Branch, may have multiple branches.  Within a branch,
only one of Start from reset, Stop and reset, Pause, or Resume is allowed per timer.  For
more on timers, see To configure a timer.
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Only one action per counter per branch is allowed.
A branch is the collection of actions after a "Then" in an Advanced Trigger step.  Some
steps, such as  Advanced 2-Way Branch, may have multiple branches.  Within a branch,
you can not both Increment and Reset the same counter.  You can increment one and
reset the other.  For more on counters, see To configure a counter.

Only one store action per branch is allowed.
A branch is the collection of actions after a "Then" in an Advanced Trigger step.  Some
steps, such as  Advanced 2-Way Branch, may have multiple branches.  Within a branch,
you can set Store sample or Don't store sample but not both in the same branch.  If you
do not specify any store actions, default storage is used.

Only one reset occurrence counter action per branch is
allowed.

A branch is the collection of actions after a "Then" in an Advanced Trigger step.  Some
steps, such as  Advanced 2-Way Branch, may have multiple branches.  Within a branch,
you can only specify Reset occurrence counter once.

No more edge resources available for this pod pair
The logic analyzer hardware can only handle two edge statements per pod pair in 400
MHz or 800 MHz timing mode, or one edge statement per pod pair in transitions only
timing mode.  The pod pairs are pod 1 & pod 2, pod 3 & pod 4, pod 5 & pod 6, and pod 7
& pod 8 (some models have fewer pods).  If the edges are on different signals, try
probing one of the signals with another channel on another pod pair.  If all the edges are
being used on the same signal, replace the "either edge" terms with "rising edge OR
falling edge".  See To insert events for how to replace "either edge".

No more pattern resources available for this pod pair
The logic analyzer hardware has a limited number of pattern (bus value) variables per
pod pair.  The pod pairs are pod 1 & pod 2, pod 3 & pod 4, pod 5 & pod 6, and pod 7 &
pod 8 (some models have fewer pods).  If the values you are checking for are on
different buses, try probing one of the buses with another pod pair.

Branch expression is too complex
The expression in one of the branches of the trigger specification is too complicated for
the logic analyzer.   The logic analyzer first combines all AND terms and then ORs the
expressions together.  AND terms that have more than 4 events use twice the resources.
Try rewriting the branch expression to use more OR terms, or delete some events.

Trigger Specification is too complex
Although no single branch expression is too complex, the total number of ANDs and ORs
has exceeded the logic analyzer's resources.  Try simplifying some expressions in some
steps, or removing steps altogether.

Replacement failed.  Maximum number of sequence levels
exceeded.

The logic analyzer translates the trigger you specified into internal sequence levels.
Different trigger functions use different numbers of internal sequence levels.  Also, the
"trigger and fill memory" action requires an additional internal sequence level each time it
is used in state acquisition mode.  One possible way to simplify the trigger specification is
to replace all other "trigger and fill memory" actions with a "goto N" action that points to
a "Find anything then trigger and fill memory" step.

Unable to insert level.  The maximum number of sequence
levels are already allocated.

The logic analyzer translates the trigger you specified into internal sequence levels.
Different trigger functions use different numbers of internal sequence levels.  Also, the
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"trigger and fill memory" action requires an additional internal sequence level each time it
is used in state acquisition mode.  One possible way to simplify the trigger specification is
to replace all other "trigger and fill memory" actions with a "goto N" action that points to
a "Find anything then trigger and fill memory" step.

Too many sequence levels.
The logic analyzer translates the trigger you specified into internal sequence levels.
Different trigger functions use different numbers of internal sequence levels.  Also, the
"trigger and fill memory" action requires an additional internal sequence level each time it
is used in state acquisition mode.  One possible way to simplify the trigger specification is
to replace all other "trigger and fill memory" actions with a "goto N" action that points to
a "Find anything then trigger and fill memory" step.

Goto action specifies an undefined level.
The last step in the trigger sequence includes the action "Goto next".  Because there is no
next level, the logic analyzer cannot run and look for a trigger.  Select Setup>Advanced
Trigger, and change the action for the last trigger step.

Counter event specified both true and false in the same
product term

In the trigger specification, at least one branch ANDs together "bus equals X" and "bus
not equal X".  Because this condition can never be true, the logic analyzer will not trigger
and does not start the acquisition.  If you intend to have it run until you press stop, use
the trigger function Run Until User Stop, found under the "Other" tab in advanced trigger.

Cannot use <,<=,>,>= for a bus with clock bits that spans
pod pairs

You have defined a bus that both spans pod pairs, and includes a clock bit.  The pod pairs
are pod 1 & pod 2, pod 3 & pod 4, pod 5 & pod 6, and pod 7 & pod 8.  (Some models
have fewer pod pairs.)  The clock bits are numbered the same as the pod they are
located on, and it is possible for them to be the channel that is not on the same pod pair
as the others.  Check the channel assignment in the bus/signal setup window.  The logic
analyzer will not run until this problem is corrected.

Cannot specify a range on a bus with clocks bits that spans
pod pairs

You have defined a bus that both spans pod pairs, and includes a clock bit.  The pod pairs
are pod 1 & pod 2, pod 3 & pod 4, pod 5 & pod 6, and pod 7 & pod 8.  (Some models
have fewer pod pairs.)  The clock bits are numbered the same as the pod they are
located on, and it is possible for them to be the channel that is not on the same pod pair
as the others.  Check the channel assignment in the bus/signal setup window.  The logic
analyzer will not run until this problem is corrected.

Warning Messages
You are currently running "Offline," so running the analyzer
is not possible.  If you wish to create "fake" data while
offline, go to "Edit -> Options" and select "Create Data When
Offline".  Note: This setting is persistent from session to
session.

The logic analyzer is running in offline mode.  Offline mode means that the logic analyzer
software does not have access to the 1680 or 1690-series hardware.  All logic analyzer
software loaded onto PCs without a 1690-series logic analyzer is in offline mode.  If you
have a logic analyzer attached, please check the connection.  For more on running with
fake data, see System Options Dialog.  Fake data is useful when learning how to use the
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logic analyzer software.

This module is already being used by another instance of the
application.  You are now working Offline.

The logic analyzer hardware is attached to an open instance of the logic analyzer
software.  If you need to acquire data, locate that instance from the Windows taskbar.
The online/offline indicator is at the bottom of the application window. In offline mode,
the software can still work with saved data.

Event specified both true and false in the same product term
In the Advanced Trigger dialog, one of the branches for one of the steps checks that an
event is both true and not true.  An event may be a bus or signal equal to a value, a
timer expiring, or a count exceeding some value.  Because of the AND combination, the
branch cannot be true.  You may want to modify the trigger to use either an OR
combination of the events, or separate them into different branches or steps.  For more
on constructing complex triggers, see To build a trigger sequence.  For more on how to
interpret the trigger sequence, see How to read event and action statements.

Timer n value checked as an event, but no start action
specified.

In the Advanced Trigger dialog, the trigger sequence checks the value of a timer that was
never started.  Timers need to be explicitly started in a previous trigger step.  See To
configure a timer for more information.

Counter n value checked as an event, but no increment action
specified.

In the Advanced Trigger dialog, the trigger sequence checks the value of a counter that is
never incremented.  Counters need to be incremented in the action statements of a
trigger step.  See To configure a counter for more information.

The Bus/Signals listed below could not be loaded from the
configuration file.  Please recheck your Trigger since it may
have changed.

The configuration file you just loaded was created on a logic analyzer with more pods
than this model.  Because of this, some buses and signals which rely on the additional
pods could not be loaded.  If these buses or signals were used in the trigger sequence,
the trigger sequence will have changed.  You may be able to work around this by
assigning different channels to the affected buses and signals, and re-creating the trigger
sequence.

Slow or missing clock in Trigger Step n...
The logic analyzer is not able to detect the state clock, and is therefore unable to take
samples and evaluate the trigger sequence.  If your target system's clock is bursty, this
may be expected behavior.  If it is not, please check all probing connections.  To verify
the clock signal is being received, you can assign the clock channels to a bus in timing
acquisition mode and acquire data.

Informational messages
Filling memory after trigger...

The logic analyzer has triggered and is filling memory.  Due to either a slow clock or
storage qualification in state acquisition mode, or infrequent transitions in transitions-only
timing acquisition mode, the logic analyzer is taking enough time to fill memory that this
message is showing.

Trigger inhibited during prestore...
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The logic analyzer is in timing acquisition mode.  In timing acquisition mode, the logic
analyzer fills the designated amount of memory before searching for the trigger.  If this
message is showing, the logic analyzer is filling memory and has not yet begun to
compare data to the trigger sequence.  To capture triggers that happen during the
beginning of a target system's boot sequence, be sure to set the trigger position in the
Sampling tab to 100% poststore.

Waiting in Trigger Step n
The logic analyzer is waiting for a sample that matches the events defined in step n of the
trigger sequence.  Sometimes the event is rare, causing long waits.  If you feel that the
logic analyzer should have triggered already, check the trigger sequence in Advanced
Trigger.  For more on triggering, see Advanced Trigger Dialog.
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Keyboard Commands
Access Menus

File Operations

Edit Operations

Search Operations

View operations

Run/Stop Operations

Window Operations

Help Operations

Miscellaneous

Access Menus
Alt+F Access to File menu

Alt+E Access to Edit menu

Alt+V Access to View menu

Alt+S Access to Setup menu

Alt+T Access to Tools menu

Alt+M Access to Markers menu

Alt+R Access to Run/Stop menu

Alt+W Access to Window menu

Alt+H Access to Help menu

File Operations
The following operations are located under File in the menu bar.

Ctrl+N File - New

Ctrl+O File - Open

Ctrl+F4 File - Close

Ctrl+S File - Save

Ctrl+P File - Print

Edit Operations
The following operations are located under Edit in the menu bar.

Ctrl+Z Edit - Undo

Ctrl+X Edit - Cut

Ctrl+C Edit - Copy

Ctrl+V Edit - Paste

Alt+I Edit - Insert Bus/Signal into Window

Alt+P Edit - Current Window Properties
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Search Operations
The following operations are located under Edit in the menu bar.

Ctrl+F Edit - Find

Shift+F3 Edit - Find Previous

F3 Edit - Find Next

Ctrl+B Edit - Go To Beginning

Ctrl+T Edit - Go To Trigger

Ctrl+E Edit - Go To End

Ctrl+G Edit - Go To

View Operations
The following operations are located under View in the menu bar.

Shift+O View - Zoom Out

Shift+I View - Zoom In

F9 View - Full Screen

F11 View - Toggle Tabbed Windows

F12 View - Toggle Status Bar

Run/Stop Operations
The following operations are located under Run/Stop in the menu bar.

F5 Run/Stop - Run

Ctrl+F5 Run/Stop - Run Repetitive

F8 Run/Stop - Stop

Shift+F8 Run/Stop - Cancel

Shift+Ctrl+F8 Run/Stop - Resume

Window Operations
The following operations are located under Window in the menu bar.

Alt+P Window - Properties

F6 Window - Toggle to Next

Shift+F6 Window - Toggle to Previous

Help Operations
The following operations are located under Help in the menu bar.

F1 Help - Help Topics

Miscellaneous
The following operations are located throughout the interface.
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Ctrl+esc Shows Windows Start bar
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Data Formats

ALA Format

The default file format for saving configuration files is ALA.  The Agilent Logic Analyzer
(ALA) file format is used only in the Agilent 1680 and 1690-series logic analyzers.  The
ALA format  is proprietary; the configuration file is not intended to be read by programs
other than the 1680 or 1690 software.  The ALA configuration file contains the
information necessary to reconstruct the display appearance, instrument settings, and
trace data (optional) that were present when the configuration file was created. The
configuration file is saved through the file menu. The configuration file is also opened
though the file menu.

The following is a general overview of what gets saved in the ALA configuration file.

General

Trigger specifications

Analyzer characteristics

Bus/Signal folders

Bus/Signal information (per bus/signal)

Marker information

Find value

Search event parameters

Symbols

Tools (e.g. inverse assemblers)

Filters

Listing display attributes

Waveform display attributes

General
� configuration File Owner, Project and Description (information as specified in the

File>Save dialog edit boxes)

� date and time the configuration file was saved

� 16xx software version that saved the configuration file

� size and screen position of the active viewer in the main window

� main window toolbar and menu items

� tools (i.e., measurement, filter and viewer subsystems) that are active

� connection graph of plug-in connectivity

Trigger specifications
� history

� occurrence counter

� storage qualifiers

� timer values

� functions and function libraries and current function state

� external arming events

� named trigger events and event lists
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� setup comments

Analyzer characteristics
� analyzer name

� number of pods

� acquisition depth

� state

� setup and hold specifications

� clock setup model

� clock settings (qualifiers and mode)

� sampling mode

� timing

� sample period

� sampling mode

� trigger position

� per-channel threshold settings

� threshold voltages

� setup dialog

� column widths, column order, column on/off

� horizontal scroll position

� vertical scroll position

� zoom factor

� selected item

� poststore specification

Bus/Signal folders
� folder name

� expanded or collapsed

� contents

Bus/Signal information (per bus/signal)
� name

� locks

� channel assignments

� number base

� polarity

Marker information
� name

� position

� measurements

� comments

� locked or not

� sample offset

� color

� hidden or not
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Find value
� marker name

� from marker ID

Search event parameters
� begin time

� end time

� event label

� event list

� occurrence count

Symbols
� symbol name

� symbol operator

� symbol context

� patterns or range values

� symbol base

Tools (e.g., inverse assemblers)
� name

� menus

� test mode

� internal labels

Note: If the configuration file is loaded into a logic analyzer that does not have a
licensed copy of the tool, the tool information is not displayed.

Filters
� filter name

� enabled or disabled

� filter events

� show filter name or not

Listing display attributes
� data area background color

� signal color

� tracker color

� show markers

� show activity indicators

� font size (bus/signal and data)

� column width (minimum and user set widths)

Waveform display attributes
� data begin position

� data end position

� row height
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� time per division

� time delay

� color

� overlay and axis

� show values

� waveform magnitude axis

� soft glitch

� show values

� waveform style (bus or magnitude)

� show soft glitch

� bus order

� expanded

� snap marker to edge

� move marker on screen

� place marker on edge

� show value tool tip

� show transition width tool tip

� show waveform magnitude axis
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CSV Format
Exportation using CSV format is primarily to be used internally and for version 1.0 only
digital data is supported.  Therefore there will be no generated data (integral or string)
from tools in an exported CSV output file.

Output is standard CSV format where the first row is column headings for time, sample,
trigger and then channel data and each successive row contains data for those columns
separated by commas.  An example exporting five samples of timing mode acquisition is
shown below.

Time,Sample,Trigger,allData,Pod2:Ch1,Pod2:Ch0,Pod1:Ch15,Pod1:Ch14,Pod1:Ch13,Pod1
:Ch12,Pod1:Ch11,Pod1:Ch10,Pod1:Ch9,Pod1:Ch8,Pod1:Ch7,Pod1:Ch6,Pod1:Ch5,Pod1:C
h4,Pod1:Ch3,Pod1:Ch2,Pod1:Ch1,Pod1:Ch0,

0,0,0,1 0000,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

0.000000050000000000000000,1,0,2 0001,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1

0.000000050000000000000000,1,0,2 0001,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1

0.000000100000000000000000,2,0,3 0002,1,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0

0.000000150000000000000000,3,0,3,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,1

0.000000150000000000000000,3,0,3,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,1

0.000000200000000000000000,4,0,1 0004,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,1,0,0
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XML Format
File>Export creates an ASCII text file that stores information using standard XML format
(<Tag> body </Tag>).  You can edit and create XML files using any text editor, such as
Notepad.  Each exported file begins with a comment indicating when the file was created,
and the keyword <Configuration>.  The file is terminated with the keyword
</Configuration>.

Example:

 <!--Exported 03:16PM Jun12,2001-->
 <Configuration>
       other sections
 </Configuration>

The XML tag format allows as many nested sections as required.  For logic analyzer data
files, the two main sections are <Setup> and <Data>.  In the XML file, comments are
nested within the <!-- and --> tags, as with HTML.  In the examples, explanatory
comments are indicated like this.

<Setup> section
The <Setup> section contains all configuration information for the logic analyzer and any
tools, such as inverse assemblers.  Logic analyzer information is contained within the
<Module> and </Module> tags.  Tool subsections are indicated with <Tool> and
</Tool>.  Each tool has its own subsection, differentiated by name.  The <Setup> section
is terminated by the </Setup> keyword.

<Module> subsection
The <Module> subsection is further divided into <Sampling> and one or more
<BusSignal> sections.  The <Sampling> section denotes how digital data was acquired.
<BusSignal> sections list the channels assigned to the particular bus or signal.  The
words appearing after the keywords are attributes (such as Name, or Acquisition) and
values (such as "Address" and "Timing").  Values always need to be contained in quotes.

Example:
       comment and <Configuration> up here
 <Setup>

 <Module Name="200MHz State/800MHz Timing Analyzer 1">

 <Sampling Acquisition="Timing" Period="0.000000001250000000000000">
 </Sampling>

 <BusSignal Name="Address">
 <Channels>0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15</Channels>
 </BusSignal>

        more BusSignal sections

 </Module>

<Tool> subsection
Tool sections give a tool name, and one or more <Label> sections.  A label will always
have a name and type. Valid types are StringLabel and Integral Label.   Filters are not
exported.
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Example:
     <Setup> and <Module></Module> up here

 <Tool Name="Arm Inverse Assembler 1">

 <Label Name="Arm Cycle information" Type="StringLabel">
 </Label>

 <Label Name="Arm Address" Type="IntegralLabel" Width="32">
 </Label>

      more Label sections

 </Tool>

 </Setup>

<Data> section
The <Data> section contains all data for both logic analyzer and any saved tools.  It also
has <Module> and <Tool> subsections.  Each nested section is terminated with a
</keyword>.

<Module> subsection
<Module> has the attributes Name, NumberOfSamples, and TriggerIndex.  The
TriggerIndex indicates which sample was the trigger point; the first sample is counted as
0.

<TimeData> subsection
The <Module> subsection may contain a <TimeData> subsection.  The <TimeData>
section exists only for non-periodic sampling (i.e. transitional timing mode or state
mode).  Any other method of sampling is periodic and as such the <Sampling> section
will simply contain a “Period” attribute and no <TimeData> section will be generated.

<DigitalData> subsection
Logic analyzer data consists of a single <DigitalData> subsection containing only digital
data samples.  There is one sample per line.  Each sample is contained between a pair of
curly braces and is formatted to appear (left to right) in the same order that the
corresponding <BusSignal> sections appear in <Setup>, delimited by commas.  For
example, “{ Bus1, Bus2, Signal1 }” where Bus1 was the first <BusSignal> section in
<Setup>, Bus2 was second, and Signal1 was third.

Example:

 <Module Name="200MHz State/800MHz Timing Analyzer 1" NumberOfSamples="60"
TriggerIndex="30">
       Notice there is no <TimeData> section because the running example is periodic
 <DigitalData>
 {7FE2,0,0},
 {7FE3,0,0},
 {7FE4,0,0},
      54 more samples here
 {1B,0,0},
 {1C,0,0},
 {1D,0,0}
 </DigitalData>
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 </Module>

<Tool> subsection
<Tool>'s only attribute is Name.  Each tool must have a unique name.  Tool data consists
of two subsections, <IntegralData> and <StringData>.

<IntegralData> and <StringData> subsections
The <IntegralData> section contains only generated data for labels in the <Label>
section of <Setup> that are Integral type.  The <StringData> section contains only
generated data for labels of String type.  As in <DigitalData>, there is one sample per
line and each sample is contained within curly braces.  The one difference between the
format of digital data and generated data is that generated data must account for
subrows.  This is accomplished through the use of square brackets that denote all
subrows for a label.  For example,
{[label1_0,label1_1],[label2_0],[label3_0,label3_1,label3_2]}” where label1 has one
subrow, label2 has no subrows and label3 has three subrows.  The first value is always
the state value and the other remaining values are subrows.

Example:

 <Tool Name="Arm Inverse Assembler 1">

 <IntegralData>
 {[0000 7FE2],[0000],[F001 0023]},
 {[0000 7FE2],[0000],[F001 0023]},
 {[0000 7FE4],[0000],[F001 0023]},
           54 more Integral Data samples
 {[0000 001A],[0000],[F001 0023]},
 {[0000 001C],[0000],[F001 0023]},
 {[0000 001C],[0000],[F001 0023]}
 </IntegralData>

 <StringData>
 {[* LSL     R0,R0,#0x0          T-[31:16]]},
 {[* LSL     R0,R0,#0x0          T-[31:16]]},
 {[* LSL     R0,R0,#0x0          T-[15:00]]},
           54 more StringData samples
 {[* LSL     R0,R0,#0x0          T-[31:16]]},
 {[* LSL     R0,R0,#0x0          T-[15:00]]},
 {[* LSL     R0,R0,#0x0          T-[15:00]]}
 </StringData>

 </Tool>

 </Data>

 </Configuration>
 <!-- end of file -->
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sampling setup.............................................................................................150
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setup menu .................................................................................................242
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signal...................................................................................................119, 136
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slave clock............................................................................................155, 158
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state clocking...............................................................................................155
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